Bug 485265 - evolution marks read emails as unread periodically
evolution marks read emails as unread periodically
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-12 12:30 EST by Wayne Feick
Modified: 2009-10-23 16:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-23 16:28:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wayne Feick 2009-02-12 12:30:30 EST
Description of problem:


Version-Release number of selected component (if applicable):

% yum list installed 'evolution*'
Loaded plugins: refresh-packagekit
Installed Packages
evolution.x86_64                             2.24.3-1.fc10             installed
evolution-conduits.x86_64                    2.24.3-1.fc10             installed
evolution-data-server.x86_64                 2.24.3-1.fc10             installed
evolution-data-server-devel.x86_64           2.24.3-1.fc10             installed
evolution-data-server-doc.x86_64             2.24.3-1.fc10             installed
evolution-exchange.x86_64                    2.24.3-2.fc10             installed
evolution-help.x86_64                        2.24.3-1.fc10             installed
evolution-perl.x86_64                        2.24.3-1.fc10             installed
evolution-spamassassin.x86_64                2.24.3-1.fc10             installed
evolution-webcal.x86_64                      2.23.91-1.fc10            installed


How reproducible:

This happens pretty consistently, multiple times a day. 

Steps to Reproduce:
1. read mail as it comes in over time
  
Actual results:

I read various mail messages and they get marked as read. Then every so often (I think when new mail arrives) evolution decides to mark many of my already read messages as unread. This is with an IMAP server.

Expected results:


Additional info:
Comment 1 Stephen Fromm 2009-02-24 12:06:12 EST
I'm seeing the same behavior on Fedora 10 with evolution.  I'm presently using:

$ rpm -qa evolution\*
evolution-perl-2.24.4-1.fc10.i386
evolution-webcal-2.23.91-1.fc10.i386
evolution-data-server-2.24.4-1.fc10.i386
evolution-2.24.4-1.fc10.i386
evolution-help-2.24.4-1.fc10.i386

However, this was also true of evolution-2.24-3-1 as well.  I did not encounter this behavior under Fedora 9 and evolution-2.22.*.
Comment 2 Mike Chambers 2009-03-07 10:26:29 EST
Can you watch it closely in a folder and as you read, can you tell if your doing anything that might cause it or trigger the mails to be read?  Can you just sit there on an email, and let the new emails come in and see if still showing as read?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Stephen Fromm 2009-03-09 12:19:15 EDT
(In reply to comment #2)
> Can you watch it closely in a folder and as you read, can you tell if your
> doing anything that might cause it or trigger the mails to be read?  Can you
> just sit there on an email, and let the new emails come in and see if still
> showing as read?

The problem has most often manifested itself when I read email at work, close my client, and then check my email from home.  In this scenario, I observed that several messages that had been marked read are now marked as unread.  Both computers are running F10.  As I stated before, this problem didn't exist before F10.  

Since this is in a work context, I can't let evolution sit idle for what would likely be several hours.  I can say that my client is configured to use IMAP and that there have been no changes on the imap server side.
Comment 4 Milan Crha 2009-03-09 14:34:05 EDT
This sounds very simlar to this:

2009-02-19  Sankar P

	** Fix for bug bnc #477535

	* camel/camel-folder-summary.c:
	Randomly mail status changes were not getting stored in server.
	Fixed the issue by unsetting correct flags.

which is included in evolution-data-server-2.24.5-1.fc10
Comment 5 Matthew Barnes 2009-10-23 12:19:42 EDT
Is this issue still present in Fedora 12?
Comment 6 Stephen Fromm 2009-10-23 12:26:41 EDT
Not that I've seen so far with F12 Beta.  I haven't seen this problem in F11 either.  Feel free to close.  Thanks for the follow-up!
Comment 7 Matthew Barnes 2009-10-23 16:28:05 EDT
Closing.  Thanks for the update!

Note You need to log in before you can comment on or make changes to this bug.