Bug 485276 - Kickstart partitioning odity
Kickstart partitioning odity
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-12 13:08 EST by A.J. Werkman
Modified: 2009-09-03 07:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-03 07:25:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description A.J. Werkman 2009-02-12 13:08:35 EST
Description of problem:

I am installing a system with two harddisks, using the following partitioning scheme:
========================================================================
zerombr yes
bootloader --location=mbr
clearpart --all --initlabel
part /boot --fstype ext3 --size=100
part pv.7 --size=0 --grow
volgroup VolGroup00 --pesize=32768 pv.7
logvol swap --fstype swap --name=LogVol01 --vgname=VolGroup00 --size=1000 --grow --maxsize=1984
logvol / --fstype ext3 --name=LogVol00 --vgname=VolGroup00 --size=1024 --grow
========================================================================

I would expect anaconda either to use only the first disk to install root and boot upon or use the first disk for boot and both disks to combine in one logical drive for root.


Version-Release number of selected component (if applicable):
anaconda 11.5.0.12-1

How reproducible:
Everytime

Steps to Reproduce:
1. Create a kickstart file containing the above lines for partitioning.
2. Install a dual disk system using the mentioned kickstart file
3. Inspect the resulting partition lay-out.
  
Actual results:
Anaconda installs the boot partition on the first disk using 100Mb leaving the rest empty and uses the second disk to install a volumegroup containing the root system.

Expected results:
I would expect anaconda either to use only the first disk to install root and boot upon or use the first disk for boot and both disks to combine in one logical drive for root.


Additional info:
Comment 1 Chris Lumens 2009-02-17 10:01:53 EST
What happens if you specify a minimum size for part pv.7?  Or if you tell it what disk to be on?
Comment 2 A.J. Werkman 2009-02-17 12:58:47 EST
At the moment I can not reproduce because in anaconda 11.5.0.19 that is now in my rawhide tree I get an exception as reported in bug #485565.

I will trie later when I receive a newer anaconda in rawhide
Comment 3 A.J. Werkman 2009-06-14 05:01:35 EDT
Chris,

Specifying a minimum size know is obligatory (anaconda 11.5.0.59, F11).

When I tell pv.7 what disk to be on, it follows my orders, ie. when I use ondisk=sda, then the boot and the pv.7 with root whill be on sda and sdb is left blank.

But the point of my bug report is, that when I give no specification on where to put everything, anaconda does not install according to sense.

As I said before logic would mean to me, that either anaconda in that case would only use the first disk to install on, or it would use both discs, and use the entire disk space.

Altough on second thought I think the second option is not valid. Since I define only one physical volume in my kickstart file and using both disks would mean there have to be two logical volumes.

So this leaves only my first option, anaconda should not put pv.7 on the second disc, but use the first disk where it already as placed the boot partition.

This however leaves the question if I want fedora to be installed on all diskspace in the system, what exact command could be used in a kickstart file. Starting with the fact, that when creating the kickstart file I do not know the number of discs that will be in every system using that kickstart file. So I do not know how many "part pv" commands I have to enclose.
Comment 4 Joel Andres Granados 2009-09-03 07:25:26 EDT
(In reply to comment #3)
> Chris,
> 
> Specifying a minimum size know is obligatory (anaconda 11.5.0.59, F11).
...
> But the point of my bug report is, that when I give no specification on where
> to put everything, anaconda does not install according to sense.

"according to sense" here is very Subjective.  To me it makes perfect sense to maximize the size of the PV and use the second drive.  In this way your installation will have more space.

> 
> As I said before logic would mean to me, that either anaconda in that case
...
> This however leaves the question if I want fedora to be installed on all
> diskspace in the system, what exact command could be used in a kickstart file.
> Starting with the fact, that when creating the kickstart file I do not know the
> number of discs that will be in every system using that kickstart file. So I do
> not know how many "part pv" commands I have to enclose.  

I believe you can use autopart.  See http://fedoraproject.org/wiki/Anaconda/Kickstart

I'm closing this bug because of 2 reasons:

1. There are 2 workarounds: 1. using autopart, and 2. specifying the disk for the PV.

2. The required behavior is a matter of opinion.  As I said previously, it is perfectly sensible to maximize partition size.

Note You need to log in before you can comment on or make changes to this bug.