Bug 485309 - renameNetworkInterface() causes nash segfault on boot
renameNetworkInterface() causes nash segfault on boot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-12 14:23 EST by James Laska
Modified: 2013-09-02 02:31 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-23 08:10:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of boot failure on real hardware (183.51 KB, image/jpeg)
2009-02-12 14:23 EST, James Laska
no flags Details
anaconda-logs.tgz (from physical hardware install) (18.72 KB, application/octet-stream)
2009-02-12 14:30 EST, James Laska
no flags Details
/init script used in my initrd img (2.39 KB, text/plain)
2009-02-12 14:56 EST, James Laska
no flags Details

  None (edit)
Description James Laska 2009-02-12 14:23:50 EST
Created attachment 331734 [details]
Screenshot of boot failure on real hardware

Description of problem:

While testing swap on iscsi (see https://fedoraproject.org/wiki/QA:Test_Plans/iSCSI_Installation_Test_plan#swap_on_iSCSI_target), nash segfaults on boot up.

Version-Release number of selected component (if applicable):
anaconda-11.5.0.17, mkinitrd-6.0.77-1.fc11

How reproducible:
2 out of 2 attempts

Steps to Reproduce:
1. Format with '/' as logical volume, 
               '/boot' as a ext3 partition, and
               swap on the iSCSI Volume
  
Actual results:

�FATAL: Error inserting crc32c_intel (/lib/modules/2.6.29-0.110.rc4.git3.fc11.i586/crc32c-intel.ko): No such device
init[1]: segfault at 9efd4d ip 00647529 sp bfed3c98 error 4 in libc-2.9.90.so[5cf000+172000]
nash received SIGSEGV!  Backtrace (10):
/bin/nash[0x8054e0d]
[0x211410]
/lib/libc.so.6(strncpy+0x29)[0x647529]
/bin/nash[0x80573ac]
/bin/nash[0x805751e]
/bin/nash[0x805417f]
/bin/nash[0x8054ccf]
/bin/nash[0x8055336]
/lib/libc.so.6(__libc_start_main+0xe5)[0x5e5735]
/bin/nash[0x804b981]


Expected results:

 * system boots

Additional info:

 * Tested in KVM and real hardware
Comment 1 James Laska 2009-02-12 14:30:34 EST
Created attachment 331735 [details]
anaconda-logs.tgz (from physical hardware install)

Attaching anaconda logs
-rw-r--r-- root/root     37146 2009-11-18 20:55 tmp/anaconda.log
-rw-r--r-- root/root     58975 2009-11-18 20:36 tmp/syslog
-rw-r--r-- root/root         0 2009-11-18 20:55 tmp/lvmout
Comment 2 James Laska 2009-02-12 14:56:10 EST
Created attachment 331736 [details]
/init script used in my initrd img
Comment 3 Hans de Goede 2009-02-13 03:02:03 EST
James,

I've done a new mkinitrd with some fixes (it fixed the nash segfault for andmike), which I think / hope will fix it for you too:
https://koji.fedoraproject.org/koji/taskinfo?taskID=1122785

The problem is that with the very special config you are using rescue mode wont work (you wont have access to the iscsi disk), so the best way to try and reproduce this with the new mkinitrd is putting the new mkinitrd in your local rawhide mirror, rerunning createrepo and then re install using the same settings that caused the problem before.
Comment 4 Hans de Goede 2009-02-17 05:48:27 EST
This is not iscsi specific but a generic bug in the renameNetworkInterface() function of nash. A fix is on its way.
Comment 5 Hans de Goede 2009-02-23 08:10:04 EST
This is fixed in mkinitrd-6.0.78, closing.
Comment 6 schorschi 2009-06-15 16:02:03 EDT
This needs to be reopened, have same issue on FC11 using mkinitrd-6.0.86-2.fc11.i586.  SO did the issue return? Or is it really related to iSCSI target?  Trying to get iSCSI target 0.4.17 working on FC11.
Comment 7 schorschi 2009-06-20 14:36:14 EDT
Update/Correction...  Not exactly the same issue.

[root@Server01 crypto]# service iscsi-target start
Starting iSCSI target service: FATAL: Error inserting crc32c_intel (/lib/modules/2.6.31-0.11.rc0.git13.fc12.i686.PAE/kernel/arch/x86/crypto/crc32c-intel.ko): No such device
FATAL: Module iscsi_trgt not found.
netlink fd: Connection refused
                                                           [FAILED]
Comment 8 James Laska 2009-06-22 11:11:59 EDT
schorschi@adelphia.net: The original bug has been closed and verified. 

The 2.6.31 kernel has not been release for Fedora 11 yet, are you testing against rawhide?

You can check which Fedora package repositories are enabled to by typing:
# yum repolist
Comment 9 schorschi 2009-06-22 20:28:20 EDT
Yes, testing again rawhide now, to see if I can recreate the results.
Comment 10 Dipak Dudhabhate 2009-09-15 02:17:18 EDT
You have to repopen this issue as i got this issue with fedora 11
Following is the error message i got

Stopping iSCSI target service:                             [FAILED]
Starting iSCSI target service: FATAL: Error inserting crc32c_intel (/lib/modules/2.6.30.5-43.fc11.x86_64/kernel/arch/x86/crypto/crc32c-intel.ko): No such device
WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
FATAL: Module iscsi_trgt not found.
netlink fd: Connection refused
                                                           [FAILED]

Note You need to log in before you can comment on or make changes to this bug.