Bug 485382 - Excessive samba 'Failed to create Administrators' errors with RID winbind backend
Excessive samba 'Failed to create Administrators' errors with RID winbind bac...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: samba (Show other bugs)
5.2
All Linux
high Severity medium
: rc
: ---
Assigned To: Simo Sorce
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-13 02:41 EST by Masahiro Okubo
Modified: 2014-03-06 01:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:54:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to change the log level (805 bytes, patch)
2009-02-13 02:50 EST, Masahiro Okubo
no flags Details | Diff

  None (edit)
Comment 2 Masahiro Okubo 2009-02-13 02:53:06 EST
I've looked through the code and found that the exact same message
regarding this failure are marked at debug level 2 in nt_user_token(), but are
marked at debug 0 in create_builtin_administrator and create_builtin_users().

Therefore, it seems to be reasonable enough to change the log level these log
message fire at to debug level 2.

I've submitted the patch to change the log level.
Comment 3 Simo Sorce 2009-02-13 11:08:51 EST
Patch looks good to me.
Comment 4 Jeremy West 2009-02-20 16:59:18 EST
Simo,

Do we have patched packages that we can provide to the customer for testing?

--jwest
Comment 5 Simo Sorce 2009-02-23 09:09:31 EST
Not at the moment, is it urgent ?
Comment 6 Jeremy West 2009-02-23 10:21:59 EST
Simo,

We'd like to give IBM and the customer the opportunity to test this patch and confirm it resolves the problem prior to the release of 5.4.  Additionally, if the patch *does* work appropriately, then we'd like to have a hotfix package available for this customer.

Thanks
Jeremy
Comment 7 Simo Sorce 2009-02-23 10:39:43 EST
ok I'll get the acks for the bug and then try to build a test package .
Comment 10 Simo Sorce 2009-02-24 10:35:39 EST
samba-3.0.33-3.9.el5 has been built
Comment 14 errata-xmlrpc 2009-09-02 07:54:46 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1416.html

Note You need to log in before you can comment on or make changes to this bug.