Bug 485414 - SELinux is preventing plugin-config (nsplugin_config_t) "execute_no_trans" to /usr/lib64/nspluginwrapper/npviewer (lib_t).
SELinux is preventing plugin-config (nsplugin_config_t) "execute_no_trans" to...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: nspluginwrapper (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
: SELinux
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-13 09:15 EST by Riku Seppala
Modified: 2009-11-08 04:46 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-08 04:46:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Riku Seppala 2009-02-13 09:15:09 EST
Summary:

SELinux is preventing plugin-config (nsplugin_config_t) "execute_no_trans" to
/usr/lib64/nspluginwrapper/npviewer (lib_t).

Detailed Description:

SELinux denied access requested by plugin-config. It is not expected that this
access is required by plugin-config and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

Sometimes labeling problems can cause SELinux denials. You could try to restore
the default system file context for /usr/lib64/nspluginwrapper/npviewer,

restorecon -v '/usr/lib64/nspluginwrapper/npviewer'

If this does not work, there is currently no automatic way to allow this access.
Instead, you can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                unconfined_u:unconfined_r:nsplugin_config_t:s0
Target Context                system_u:object_r:lib_t:s0
Target Objects                /usr/lib64/nspluginwrapper/npviewer [ file ]
Source                        plugin-config
Source Path                   /usr/lib64/nspluginwrapper/plugin-config
Port                          <Unknown>
Host                          localhost.localdomain
Source RPM Packages           nspluginwrapper-1.3.0-2.fc11
Target RPM Packages           nspluginwrapper-1.3.0-2.fc11
Policy RPM                    selinux-policy-3.6.5-3.fc11
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall_file
Host Name                     localhost.localdomain
Platform                      Linux localhost.localdomain
                              2.6.29-0.110.rc4.git3.fc11.x86_64 #1 SMP Wed Feb
                              11 16:25:44 EST 2009 x86_64 x86_64
Alert Count                   2
First Seen                    Fri 13 Feb 2009 04:06:49 PM EET
Last Seen                     Fri 13 Feb 2009 04:09:28 PM EET
Local ID                      b375e302-fd16-4215-aee1-0f3bacc4ab89
Line Numbers                  

Raw Audit Messages            

node=localhost.localdomain type=AVC msg=audit(1234534168.519:53): avc:  denied  { execute_no_trans } for  pid=3182 comm="plugin-config" path="/usr/lib64/nspluginwrapper/npviewer" dev=dm-0 ino=62551 scontext=unconfined_u:unconfined_r:nsplugin_config_t:s0 tcontext=system_u:object_r:lib_t:s0 tclass=file

node=localhost.localdomain type=SYSCALL msg=audit(1234534168.519:53): arch=c000003e syscall=59 success=no exit=-13 a0=606f00 a1=7fffd7ae5cb0 a2=7fffd7af0790 a3=7fffd7ae7ac0 items=0 ppid=3181 pid=3182 auid=500 uid=500 gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="plugin-config" exe="/usr/lib64/nspluginwrapper/plugin-config" subj=unconfined_u:unconfined_r:nsplugin_config_t:s0 key=(null)
Comment 1 Riku Seppala 2009-03-13 04:32:57 EDT
Already fixed? I don't see this anymore but since status is assigned I haven't closed this.
Comment 2 Bug Zapper 2009-06-09 07:21:04 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.