Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 485518 - Cherokee should not pull Lighttpd as dependency
Cherokee should not pull Lighttpd as dependency
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cherokee (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Pavel Lisý
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-13 16:19 EST by Paul Lange
Modified: 2009-02-16 17:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 17:02:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Lange 2009-02-13 16:19:04 EST
Description of problem:

When I try to install Cherokee on F10 it pulls 3 more dependencies:
* lighttpd
* lighttpd-fastcgi
* spawn-fcgi

I'm not an expert on this but as far as I know lighttpd is a completely different webserver and should not be pulled.
Comment 1 Pavel Lisý 2009-02-15 12:20:56 EST
Cherokee uses in source tarbal code from lighttpd source 
(/usr/bin/spawn-fcgi, /usr/share/man/man1/spawn-fcgi.1.gz)

This have made conflict between these two packages (see https://bugzilla.redhat.com/show_bug.cgi?id=472749 and https://bugzilla.redhat.com/show_bug.cgi?id=472747)
and was solved by using spawn-fcgi from lighttpd-fastcgi package. 

We can make lighttpd-fastcgi independent on lighttpd but this is more for lighttpd bugzilla record.

Do you have better solution?
Comment 2 Paul Lange 2009-02-15 15:25:24 EST
I don't have much knowledge on how to handle such problems. I was only a bit surprised that yum pulls lighttpd when I tried to install cherokee.

So maybe it's the best solution to make lighttpd-fastcgi independent from lighttpd as you said.
Comment 3 Pavel Lisý 2009-02-16 05:59:51 EST
I've made next research and this is result. 
This bug was solved already (it depends on spawn-fcgi only) but new rpm wasn't pushed to update yet. 

I have made update request in bodhi, see
https://admin.fedoraproject.org/updates/cherokee-0.11.6-1.fc9
https://admin.fedoraproject.org/updates/cherokee-0.11.6-1.fc10

I am not sure how quick it will be in stable update. You can maybe increase karma for that packages. 

Can I close this bug now?
Comment 4 Paul Lange 2009-02-16 15:54:14 EST
It's already in stable.

This solves this bug. Thank you!

Note You need to log in before you can comment on or make changes to this bug.