This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 485520 - Alternate IMAP trash folder fails to Undo Delete
Alternate IMAP trash folder fails to Undo Delete
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-13 16:41 EST by Christopher Tubbs
Modified: 2009-02-16 11:29 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 11:29:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 417167 None None None Never

  None (edit)
Description Christopher Tubbs 2009-02-13 16:41:54 EST
Description of problem:
I'm using Gmail's IMAP and have found that when I add the advanced preference, mail.server.server#.trash_folder_name = "[Gmail]/Trash", then I am no longer able to "undo" deletions from the trash folder.

Version-Release number of selected component (if applicable):
thunderbird-2.0.0.19-1.fc10.i386

How reproducible:
100% on my setup

Steps to Reproduce:
1. Configure Gmail IMAP according to Gmail instructions in thunderbird
2. Change trash folder name with: user_pref("mail.server.serverX.trash_folder_name", "[Gmail]/Trash");
3. Restart thunderbird a few times for it to update the imap folders.
4. Check email and delete something from your Gmail inbox in thunderbird.
5. Attempt to "undo" (ctrl-Z or from edit menu)
  
Actual results:
Nothing happens. Mail remains in Trash folder.

Expected results:
Mail should be moved back to Inbox (or folder it was deleted from) from the trash folder.

Additional info:
N/A
Comment 1 Matěj Cepl 2009-02-14 18:27:12 EST
GMail engineers explicitly advice against doing this
http://lifehacker.com/software/geek-to-live/turn-thunderbird-into-the-ultimate-gmail-imap-client-314574.php

Closing as NOTABUG.
Comment 2 Matěj Cepl 2009-02-14 18:29:44 EST
Actually, some people suggest mapping "All Mails" as your TB Trash folder to work better.
Comment 3 Matěj Cepl 2009-02-14 18:30:18 EST
Actually, some people suggest mapping "All Mails" as your TB Trash folder to work better.

http://blog.rameshbhaskar.com/2007/10/27/configuring-thunderbird-for-gmail-imap-the-way-it-should-be-done/
Comment 4 Christopher Tubbs 2009-02-14 20:44:37 EST
I understand the ramifications of doing this, as well as the reasons why Gmail advises against this. However, their advise does not pertain to the proper functionality of Thunderbird, nor does their backend implementation of their IMAP server.

In fact, the advice they give has more to do with unexpected side effects of deletes because of labels. Once again, though, this does not pertain to the proper functionality of Thunderbird.

As for the suggestion to use "All Mail" as the trash folder, the Undo problem still persists, plus you run the risk of "emptying" all archived messages with a simple slip of the "empty trash" option (obviously a bad thing).

Regardless of Gmail, Thunderbird should be able to handle moving a message back to the folder it was deleted from. After all, I can do it manually by copy/paste from Trash folder to Inbox, so why can't Thunderbird automatically do it when I hit Undo?

In short, this is certainly a bug, because a feature of Thunderbird that simply moves a message from one folder to another is not working. The issue that the developers should address with regard to this bug, is whether the problem is caused by Thunderbird not being able to find the message it deleted because of Gmail's relabeling of the messages on the server (something that cannot be addressed by the developers, obviously, but perhaps can be a special case since Thunderbird has already made efforts to integrate Gmail, as POP, into Thunderbird), or because it doesn't recognize it's own configuration of the Trash folder name in the implementation of Undo.

If the problem is because Thunderbird's "Undo" does not properly function because it does not take into account advanced configuration of the trash folder name, then this is a bug that SHOULD be fixed as soon as possible (given other development priorities of course). If the problem is Gmail's relabeling, then at the very least, it would be nice for Thunderbird to at least consider recognizing the special case.

In either case, it is certainly a bug when Thunderbird doesn't handle a normal, and common function for an Imap server configuration that is not that unusual.
Comment 5 Matěj Cepl 2009-02-15 08:38:06 EST
I can understand your point, but we really don't have capacity on making Thunderbird support actions for the IMAP server which actively advises against doing so. If you really believe that your idea is worthy, please take your struggle to upstream and file a bug report in the the upstream bugzilla located at http://bugzilla.mozilla.org in the Thunderbird product.

Once you've filed your bug report to the upstream bugzilla, if you paste the new bug URL here, Red Hat will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Setting status to NEEDINFO, and awaiting upstream bug report URL for tracking.

Thanks in advance.
Comment 6 Christopher Tubbs 2009-02-15 12:24:27 EST
After some testing with another IMAP server, I determined that it must be a Gmail specific bug. Also, it's already being tracked, in detail, upstream at:

https://bugzilla.mozilla.org/show_bug.cgi?id=417167
Comment 7 Matěj Cepl 2009-02-16 11:29:16 EST
OK, we will follow this bug upstream and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.