Bug 485528 - gnome-help crashes and generates a bug report
gnome-help crashes and generates a bug report
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yelp (Show other bugs)
10
i386 Linux
low Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-13 17:49 EST by mdeggers
Modified: 2009-06-21 09:36 EDT (History)
3 users (show)

See Also:
Fixed In Version: yelp-2.26.0-3.fc11.i586
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-21 09:36:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Trace generated after debuginfo-install yelp (14.98 KB, text/plain)
2009-02-16 00:26 EST, mdeggers
no flags Details

  None (edit)
Description mdeggers 2009-02-13 17:49:13 EST
Description of problem:
gnome-help, either from the System-->Help menu or /usr/bin/gnome-help crashes without displaying any help information.

Version-Release number of selected component (if applicable):
yelp-2.24.0-5.fc10.i386

How reproducible:
100%

Steps to Reproduce:
1. Start gnome-help from the menu (System-->Help)
2. Wait for crash

1. Start /usr/bin/gnome-help from the command line
2. Wait for crash
  
Actual results:
This is the output from the command line.

$ gnome-help 
OMF category 'System|Configuration|Configuration Tools' not recognised, ignoring.
OMF category 'System|Configuration|Configuration Tools' not recognised, ignoring.
OMF category 'System|Configuration|Configuration Tools' not recognised, ignoring.
OMF category 'System|Configuration|Configuration Tools' not recognised, ignoring.
OMF category 'System|Configuration|Configuration Tools' not recognised, ignoring.
OMF category 'System|Configuration|Configuration Tools' not recognised, ignoring.
Error: Malformed line (no section).  Ignoring entry
Error: Malformed line (no section).  Ignoring entry
Error: Malformed line (no section).  Ignoring entry
Error: Malformed line (no filename).  Ignoring entry
Error: Malformed line (no filename close).  Ignoring entry
1f40bacf-299e-bea4-10d4ff46-027ba6f4 is dumped

Expected results:
Help manual is displayed.

Additional info:
I have multiple windowing systems installed (Gnome, KDE, Fluxbox, Windowmaker).
Comment 1 Matthew Barnes 2009-02-15 17:52:58 EST
Thanks for taking the time to report this bug.
Without a stack trace from the crash it's very hard to determine what caused it.
Can you get us a stack trace? Please see http://live.gnome.org/GettingTraces for more information on how to do so. Thanks in advance!
Comment 2 mdeggers 2009-02-16 00:26:45 EST
Created attachment 332002 [details]
Trace generated after debuginfo-install yelp

This is the trace I got from Gnome's bug buddy after doing:

debuginfo-install yelp.
Comment 3 Matthew Barnes 2009-02-16 00:50:40 EST
Thanks, it looks like that has everything I need to proceed.
Comment 4 Jon Dufresne 2009-02-16 13:56:45 EST
Since all requested info was received, am marking as assigned.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 John J. McDonough 2009-04-20 21:22:56 EDT
I have been testing the F11 Preview release notes and observed a consistent crash with the Oriya language.  At this time there are perhaps a dozen languages translated and this was the only one that crashed.

Went back to a virgin Fedora 10 and got the same result when logging i2 with Oriya language.  the opening window gets mostly displayed and then yelp crashes.
Comment 6 Matthew Barnes 2009-06-21 09:36:32 EDT
The originally reported crash seems not to occur in Fedora 11.
Closing, but please reopen if you see it again in Fedora 11 or later.

Note You need to log in before you can comment on or make changes to this bug.