Bug 485536 - Recent upstream kernel fails to install properly due to mkinitrd/sysfs issue
Recent upstream kernel fails to install properly due to mkinitrd/sysfs issue
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-13 19:08 EST by James Morris
Modified: 2009-02-13 19:53 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-13 19:53:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Morris 2009-02-13 19:08:20 EST
Description of problem:

I'm unable to install kernels with recent upstream kernels running because mkinitrd seems to be unable to find the block devices on the system:

WARNING: /sys/block/dm-0 is a not a block sysfs path, skipping

Looking at the mkinitrd source, it is checking for:

if [[ ! "$sysfs" =~ '^/sys/devices/.*/block/.*$' ]]; then
        error "WARNING: $sysfs is a not a block sysfs path, skipping"


On my upstream kernels of 2.6.29-rc3 and -rc4 (possibly others), this fails.

On older kernels, you can find:

/sys/devices/virtual/block/

but it is gone now.

Version-Release number of selected component (if applicable):

mkinitrd-6.0.77-1.fc11.x86_64
Comment 1 James Morris 2009-02-13 19:53:00 EST
Disregard, I had CONFIG_SYSFS_DEPRECATED* selected, which is apparently evil.

Note You need to log in before you can comment on or make changes to this bug.