Bug 485622 - Partitioning traceback with new pyparted - KeyError: 's'
Partitioning traceback with new pyparted - KeyError: 's'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 485943 485987 486058 486123 486220 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-15 08:28 EST by Joachim Frieben
Modified: 2009-02-20 18:15 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-20 18:15:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Exception report for anaconda 11.5.0.19 (101.69 KB, text/plain)
2009-02-15 08:28 EST, Joachim Frieben
no flags Details
Exception report for anaconda 11.5.0.19-1 on x86 (Intel PR440FX) (73.98 KB, text/plain)
2009-02-16 09:17 EST, Joachim Frieben
no flags Details
0001-Handle-request.drive-being-a-list-or-string-485622.patch (13.81 KB, patch)
2009-02-19 17:32 EST, David Cantrell
no flags Details | Diff
0002-Ensure-request.drive-is-always-a-list-485622.patch (7.35 KB, patch)
2009-02-20 17:17 EST, David Cantrell
no flags Details | Diff

  None (edit)
Description Joachim Frieben 2009-02-15 08:28:34 EST
Created attachment 331967 [details]
Exception report for anaconda 11.5.0.19

Description of problem:
After booting from boot.iso as of 2009-02-15, an exception occurs when an existing existing logical volume is double clicked for further editing. 'Bug buddy' appears on the screen and displays a traceback which is attached to this report.

Version-Release number of selected component (if applicable):
anaconda-11.5.0.19-.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Boot "boot.iso" from USB stick.
2. Choose custom layout in order to reuse an existing VG.
3. Click the first LV in the volume window.
  
Actual results:
Anaconda throws an exception.

Expected results:
Volume gets opened for setting the mount point etc.

Additional info:
- The exception happens for earlier version of anaconda including the
  F11-Alpha boot image.
- F10 was not affected by this bug.
Comment 1 Joachim Frieben 2009-02-16 09:17:50 EST
Created attachment 332042 [details]
Exception report for anaconda 11.5.0.19-1 on x86 (Intel PR440FX)

Just happens here as on a Tyan Tomcat K8E running the x86_64 bit version. No problem when running the partitioner from the F11 Alpha i686 live CD. Of course, the corresponding boot.iso mentioned in the initial report could not work as stage2.img was still downloaded from the current rawhide tree. Maybe a problem with pyparted-2.0.0-1?
Comment 2 Chris Lumens 2009-02-17 11:11:38 EST
*** Bug 485943 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lumens 2009-02-17 14:38:16 EST
*** Bug 485987 has been marked as a duplicate of this bug. ***
Comment 4 Joachim Frieben 2009-02-18 06:55:19 EST
No improvement for "rawhide" as of 2009-02-18:
- anaconda-11.5.0.19-1.x86_64
- pyparted-2.0.1-1.fc11.x86_64
- kernel-2.6.29-0.124.rc5.fc11.x86_64
Comment 5 Chris Lumens 2009-02-18 09:49:13 EST
Yep, that's why this bug is still in NEW.
Comment 6 Chris Lumens 2009-02-18 10:04:22 EST
*** Bug 486058 has been marked as a duplicate of this bug. ***
Comment 7 Chris Lumens 2009-02-18 11:45:37 EST
*** Bug 486123 has been marked as a duplicate of this bug. ***
Comment 8 Chris Lumens 2009-02-18 18:26:32 EST
*** Bug 486220 has been marked as a duplicate of this bug. ***
Comment 9 David Cantrell 2009-02-19 17:32:11 EST
Created attachment 332645 [details]
0001-Handle-request.drive-being-a-list-or-string-485622.patch

Patch to fix the issue.  Under review now.
Comment 10 David Cantrell 2009-02-20 17:17:29 EST
Created attachment 332771 [details]
0002-Ensure-request.drive-is-always-a-list-485622.patch
Comment 11 David Cantrell 2009-02-20 18:15:55 EST
Fixed in anaconda-11.5.0.23-1

Note You need to log in before you can comment on or make changes to this bug.