Bug 485650 - broken tables because of adjustColumnWidths in docbook xsl
broken tables because of adjustColumnWidths in docbook xsl
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: docbook-style-xsl (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-15 17:23 EST by Muayyad Alsadi
Modified: 2009-02-18 11:35 EST (History)
3 users (show)

See Also:
Fixed In Version: docbook-style-xsl-1.74.1-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-18 11:35:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Muayyad Alsadi 2009-02-15 17:23:24 EST
Description of problem:
I was try to help a brother translating SELinux User Guide, and every thing fails.
I tried to trace the reason and after several tests, I blame docbook-style-xsl
I tried xsltproc manually using fedora's xsl (and I also tried 1.73 from F8) and an upstream snapshot of xsl, only F10 and F 11 fails

Version-Release number of selected component (if applicable):
docbook-style-xsl-1.74.0-7.fc11.noarch

How reproducible:
always

Steps to Reproduce:
try to generate selinux user guide using publican or using manually with xslt proc
  
Actual results:

Writing sect-Security-Enhanced_Linux-Targeted_Policy-Unconfined_Processes.html for section(sect-Security-Enhanced_Linux-Targe
ted_Policy-Unconfined_Processes)
No adjustColumnWidths function available.
make: *** [html-ar-AR] Error 10

Expected results:
generating html
Comment 1 Ondrej Vasik 2009-02-18 07:54:02 EST
Thanks for report... So do I understand correctly that it does work correctly with F-8 stylesheets? Function adjustColumnWidths was added to xsl-stylesheets to workaround passivetex issue and the patch is already included in 1.73 ... will try to reproduce your problem, could you please check if it still does occur with new upstream release built in Fedora Rawhide? (docbook-style-xsl-1.74.1-1.fc11)
Comment 2 Muayyad Alsadi 2009-02-18 11:15:20 EST
> So do I understand correctly that it does work correctly with F-8 stylesheets? 
yes, version tested was 1.73.1 and yes grep show that it also contains the function but it works there

> could you please check if it still does occur with new upstream release built in Fedora Rawhide?

yes, it works fine in docbook-style-xsl-1.74.1-1.fc11

I'll recommend pushing similar update to F10 and F9
if that is not harmful
Comment 3 Ondrej Vasik 2009-02-18 11:35:52 EST
Great... so closing that bugzilla RAWHIDE. Thanks for feedback . Will consider if I'll update to 1.74.1 or fix the adjustColumnWidths patch in released Fedora's later (perhaps next week)...

Note You need to log in before you can comment on or make changes to this bug.