Bug 485682 - Replace use of gethostbyname() with getaddrinfo()/getnameinfo()
Replace use of gethostbyname() with getaddrinfo()/getnameinfo()
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.1
All Linux
high Severity urgent
: 1.1.1
: ---
Assigned To: Andrew Stitcher
Frantisek Reznicek
:
Depends On:
Blocks: 489351
  Show dependency treegraph
 
Reported: 2009-02-16 04:08 EST by Gordon Sim
Modified: 2015-11-15 19:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 12:17:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Sim 2009-02-16 04:08:17 EST
See http://people.redhat.com/drepper/userapi-ipv6.html
Comment 1 Andrew Stitcher 2009-03-09 15:27:19 EDT
This turns out to be much worse than it sounds:
gethostbyname() isn't a thread safe API and could cause (and may have been observed to cause) errors when multiple threads do gethostbyname() at the same time.
Comment 3 Frantisek Reznicek 2009-03-16 05:32:37 EDT
Qpid C++ code now doesn't use gethostbyname() call. Verified on svn tree revision 752581.

-> VERIFIED
Comment 5 errata-xmlrpc 2009-04-21 12:17:51 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0434.html

Note You need to log in before you can comment on or make changes to this bug.