Bug 485685 - Embolden Font with embeddedbitmap is ugly in firefox.
Embolden Font with embeddedbitmap is ugly in firefox.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
: 490281 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-16 04:58 EST by sangu
Modified: 2009-03-17 23:40 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.6.99.behdad.20090317-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-17 23:40:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
embeddedbitmap bold in firefox ( http://cndic.naver.com/font.nhn ) (11.69 KB, image/png)
2009-02-16 04:58 EST, sangu
no flags Details
Embolden font in fontconfig-2.6.95-1.git.66.gb162bfb (3.99 KB, image/png)
2009-02-16 07:13 EST, sangu
no flags Details

  None (edit)
Description sangu 2009-02-16 04:58:36 EST
Created attachment 332015 [details]
embeddedbitmap bold in firefox ( http://cndic.naver.com/font.nhn )

Description of problem:
Using bold in firefox, embeddedbitmap option does't work.

Then, the others gtk2 programs work well.

Version-Release number of selected component (if applicable):
2.6.97-2.g945d6a4.fc11

How reproducible:
always in firefox

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 sangu 2009-02-16 07:13:13 EST
Created attachment 332027 [details]
Embolden font in fontconfig-2.6.95-1.git.66.gb162bfb
Comment 2 sangu 2009-03-10 11:39:11 EDT
This bug still happens in 2.6.98-1.gb39c36a.fc11.
Comment 3 sangu 2009-03-17 08:24:36 EDT
This issue happens by this patch http://cgit.freedesktop.org/~behdad/fontconfig/commit/?id=10609af4aa4030a15c19573198462fa002d2ef13 < https://bugs.freedesktop.org/show_bug.cgi?id=19904 >

After removing the patch in /etc/fonts/conf.d/90-synthetic.conf,  embolden rendering of embeddedbitmap font becomes good.
Comment 4 Behdad Esfahbod 2009-03-17 12:25:57 EDT
*** Bug 490281 has been marked as a duplicate of this bug. ***
Comment 5 Behdad Esfahbod 2009-03-17 13:16:50 EDT
Built fontconfig-2.6.99.behdad.20090317-1.fc11 which removes that patch.  Requested it to be tagged for f11 beta.
https://fedorahosted.org/rel-eng/ticket/1390
Comment 6 sangu 2009-03-17 23:40:09 EDT
Fixed in fontconfig-2.6.99.behdad.20090317-1.fc11 < http://koji.fedoraproject.org/koji/buildinfo?buildID=94516 >

Note You need to log in before you can comment on or make changes to this bug.