Bug 485698 - missing options in rhn-satellite-exporter.8
missing options in rhn-satellite-exporter.8
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization (Show other bugs)
530
All Linux
low Severity low
: ---
: ---
Assigned To: Milan Zazrivec
Jan Hutař
:
Depends On:
Blocks: 457071
  Show dependency treegraph
 
Reported: 2009-02-16 08:53 EST by Jan Hutař
Modified: 2009-09-10 16:04 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:04:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2009-02-16 08:53:50 EST
Description of problem:
There are missing options in the rhn-satellite-exporter.8 man-page, but '--help' lists them.


Version-Release number of selected component (if applicable):
spacewalk-backend-tools-0.5.6-1.el5sat


How reproducible:
always


Steps to Reproduce:
1. # rhn-satellite-exporter --help
2. # man rhn-satellite-exporter


Actual results:
Missing in man page:
	--start-date
	--end-date
	--hard-links
	--make-isos
	--help, -h
	--usage


Expected results:
All options should be in both outputs


Additional info:
Used mmalik's script for this (gives some false-positives):
# cd /mnt/qa/scratch/mmalik/options-comparator/
# ./compare-options.sh `type -p rhn-satellite-exporter`
Program path:
	/usr/bin/rhn-satellite-exporter
Guessing man page path:
	/usr/share/man/man8/rhn-satellite-exporter.8.gz
The binary analysis was NOT done
Doing man page vs. usage message comparison

The program reported 27 option(s)
The man page reported 21 option(s)
20 COMMON option(s):
	--channel
	--db
	--debug-level
	--dir
	--email
	--list-channels
	--list-steps
	--no-errata
	--no-kickstarts
	--no-packages
	--no-rpms
	--print-configuration
	--print-report
	--step
	--traceback-mail
	--verbose
	-c
	-d
	-p
	-v
7 option(s) reported by the program ONLY:
	--end-date
	--hard-links
	--help
	--make-isos
	--start-date
	--usage
	-h
1 option(s) reported by the man page ONLY:
	-m
Comment 1 Jan Hutař 2009-02-17 06:37:14 EST
Just few notes about man-page:

       If you are exporting one of the base channels provided by RHN, you will
       also need to export the tools channel associated with that base channel
       in order to kickstart machines to the distribution in the base channel.
       For  instance,  if you export rhel-i386-as-4 you should also export the
       rhn-tools-rhel-4-as-i386 channel in order to kickstart machines to RHEL
       4  AS.  This  is  because the tools channels contain the auto-kickstart
       packages that install packages for kickstarting a machine  through  the
       Satellite.
       * Is this still true as we have that new provisioning subsystem?

       When  importing  an exported channel into a satellite on which you have
       not run satellite-sync, you will need to  use  satellite-sync’s  --rhn-
       cert option to import the entitlements cert.
       * "on which you have not run satellite-sync" -> "which was not
         activated"?

       -d --dir
       * "-d --dir" -> "-dDIR, --dir=DIR"?

       -p --print-configuration
       * "-p --print-configuration" -> "-p, --print-configuration"?

       --db   Extract information from this database. The  value  must  be  an
              Oracle connection string that is configured in your tnsnames.ora
              file.
       * satellite-sync uses different syntax for this option, so not sure if
         this is true (?)

All this are pretty small issues, but I have thought I should report them.
Comment 2 Milan Zazrivec 2009-02-18 10:40:00 EST
spacewalk.git master: cf7ba9f6ab58580677fb9ba0b8a879c8ba6c3f42
Comment 3 Jan Hutař 2009-03-30 05:08:25 EDT
Hello, these seems fine, thanks:

       --start-date=START_DATE
              The start date limit that the last modified dates are compared against. Must be in  the
              format ’YYYYMMDDHH24MISS’.

       --end-date=END_DATE
              The  end  date  limit that the last modified dates are compared against. Must be in the
              format ’YYYYMMDDHH24MISS’.

       --hard-links
              Hard link exported packages and kickstarts to original files.

       --make-isos=MAKE_ISOS
              Create channel dump isos directory called  satellite-isos.   Usage:  --make-isos=cd  or
              dvd.
Comment 4 Jan Hutař 2009-03-30 05:11:04 EDT
But could you please comment on these?:

* Missing in man page:
       -h
       --usage

* Is this still true as we have that new provisioning subsystem?
       If you are exporting one of the base channels provided by RHN, you will
       also need to export the tools channel associated with that base channel
       in order to kickstart machines to the distribution in the base channel.
       For  instance,  if you export rhel-i386-as-4 you should also export the
       rhn-tools-rhel-4-as-i386 channel in order to kickstart machines to RHEL
       4  AS.  This  is  because the tools channels contain the auto-kickstart
       packages that install packages for kickstarting a machine  through  the
       Satellite.

* "on which you have not run satellite-sync" -> "which was not activated"?
       When  importing  an exported channel into a satellite on which you have
       not run satellite-sync, you will need to  use  satellite-sync’s  --rhn-
       cert option to import the entitlements cert.

* "-d --dir" -> "-dDIR, --dir=DIR" (same as "-c" syntax)?
       -d --dir

* "-p --print-configuration" -> "-p, --print-configuration" (same as "-c" syntax)?
       -p --print-configuration

* satellite-sync uses different syntax for this option, so not sure if this is true (?)
       --db   Extract information from this database. The  value  must  be  an
              Oracle connection string that is configured in your tnsnames.ora
              file.
Comment 5 Milan Zazrivec 2009-03-30 06:10:55 EDT
(In reply to comment #4)
> But could you please comment on these?:
> 
> * Missing in man page:
>        -h

Fixed in spacewalk.git master: 655f6165469c7b799fdb32b8a7b79d18a32d70dc

>        --usage

rhn-satellite-exporter does not report --usage as its option (or at least
I can't see it). Can you please show me some specific action that leads you
to believe it does?

> 
> * Is this still true as we have that new provisioning subsystem?
>        If you are exporting one of the base channels provided by RHN, you will
>        also need to export the tools channel associated with that base channel
>        in order to kickstart machines to the distribution in the base channel.
>        For  instance,  if you export rhel-i386-as-4 you should also export the
>        rhn-tools-rhel-4-as-i386 channel in order to kickstart machines to RHEL
>        4  AS.  This  is  because the tools channels contain the auto-kickstart
>        packages that install packages for kickstarting a machine  through  the
>        Satellite.

Yes. You still need to export auto-kickstart packages for the benefit of
satellites that still need them (3.x satellites for example).

> * "on which you have not run satellite-sync" -> "which was not activated"?
>        When  importing  an exported channel into a satellite on which you have
>        not run satellite-sync, you will need to  use  satellite-sync’s  --rhn-
>        cert option to import the entitlements cert.

No. Satellite activation and syncing the content are not the same thing.

> * "-d --dir" -> "-dDIR, --dir=DIR" (same as "-c" syntax)?
>        -d --dir

spacewalk.git master: a5ff38524c1c3b35e5eb8b72f107a6b7793c13a9

> * "-p --print-configuration" -> "-p, --print-configuration" (same as "-c"
> syntax)?
>        -p --print-configuration

spacewalk.git master: 2b88c5e2f36168c143205b4bd18dc13d40e45a3d

> * satellite-sync uses different syntax for this option, so not sure if this is
> true (?)
>        --db   Extract information from this database. The  value  must  be  an
>               Oracle connection string that is configured in your tnsnames.ora
>               file.  

Where do you see the different syntax?
Comment 6 Jan Hutař 2009-03-30 09:00:49 EDT
Wow, thanks!

> rhn-satellite-exporter does not report --usage as its option (or at least
> I can't see it). Can you please show me some specific action that leads you
> to believe it does?

Err, my mystake.

>> * satellite-sync uses different syntax for this option, so not sure if this
>> is true (?)
>>        --db  Extract information from this database. The  value  must  be  an
>>              Oracle connection string that is configured in your tnsnames.ora
>>              file.  
> 
> Where do you see the different syntax? 

In satellite-sync man page there is:

       -dDBUSERNAME/DBPASSWORD@DB, --db=DBUSERNAME/DBPASSWORD@DB
              alternative database connection string (username/password@sid).

so I would expect something similar here (I mean these two utilities have similar option with different syntax?). But probably that is OK.
Comment 7 Milan Zazrivec 2009-04-09 09:10:31 EDT
Fix present in spacewalk-backend-tools-0.5.28-3 or 
Satellite-5.3.0-RHEL5-re20090403.2
Comment 8 Milan Zazrivec 2009-05-21 07:23:20 EDT
spacewalk.git master: 91dc64dbebea392a67edb655a83229a65fd5dfa5
spacewalk.git VADER: 7ca3a1c9de87733a6a6ab9d3231bbd74a740c51f
Comment 9 Milan Zazrivec 2009-05-25 08:54:41 EDT
spacewalk-backend-tools-0.5.28-15
Comment 10 Jan Hutař 2009-05-29 03:47:36 EDT
VERIFIED in spacewalk-backend-tools-0.5.28-15.el5sat
Comment 11 Brandon Perkins 2009-09-10 16:04:28 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.