Bug 485701 - Traceback installing rawhide-i386 in KVM guest
Traceback installing rawhide-i386 in KVM guest
Status: CLOSED DUPLICATE of bug 485565
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:be9f294050023adb5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-16 09:07 EST by James Laska
Modified: 2013-09-02 02:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 10:38:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (52.36 KB, text/plain)
2009-02-16 09:07 EST, James Laska
no flags Details
Attached traceback automatically from anaconda. (48.48 KB, text/plain)
2009-02-16 09:07 EST, James Laska
no flags Details
Attached traceback automatically from anaconda. (67.80 KB, text/plain)
2009-02-16 12:38 EST, Jesse Keating
no flags Details
Attached traceback automatically from anaconda. (52.38 KB, text/plain)
2009-02-17 09:54 EST, James Laska
no flags Details
Attached traceback automatically from anaconda. (54.09 KB, text/plain)
2009-02-19 08:07 EST, James Laska
no flags Details

  None (edit)
Description James Laska 2009-02-16 09:07:40 EST
This bug was filed automatically by anaconda.
Comment 1 James Laska 2009-02-16 09:07:43 EST
Created attachment 332040 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2009-02-16 09:07:54 EST
Created attachment 332041 [details]
Attached traceback automatically from anaconda.
Comment 3 James Laska 2009-02-16 09:34:39 EST
Adding short traceback for anyone searching bugzilla.

anaconda 11.5.0.19 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/autopart.py", line 79, in bootRequestCheck
    if not part:
  File "/usr/lib/anaconda/autopart.py", line 1054, in doPartitioning
    ret = bootRequestCheck(req, diskset)
  File "/usr/lib/anaconda/autopart.py", line 1520, in doAutoPartition
    doPartitioning(diskset, partitions, doRefresh = 0)
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 226, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/text.py", line 637, in run
    (step, instance) = anaconda.dispatch.currentStep()
  File "/usr/bin/anaconda", line 1013, in <module>
    anaconda.intf.run(anaconda)
UnboundLocalError: local variable 'part' referenced before assignment
Comment 4 Chris Lumens 2009-02-16 10:38:17 EST
Same underlying cause as 485565, just occurring in a different place.  For some reason, the request.drive list is empty so there's never any part getting set.  I'd consider setting part to None beforehand, but I like that it let us know now there's a problem, rather than it occurring in an ever more hard to find place.

*** This bug has been marked as a duplicate of bug 485565 ***
Comment 5 Jesse Keating 2009-02-16 12:38:13 EST
Created attachment 332068 [details]
Attached traceback automatically from anaconda.
Comment 6 James Laska 2009-02-17 09:54:40 EST
Created attachment 332223 [details]
Attached traceback automatically from anaconda.
Comment 7 James Laska 2009-02-19 08:07:23 EST
Created attachment 332551 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.