Bug 485702 - fontpackages-devel should require fontconfig
fontpackages-devel should require fontconfig
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fontpackages (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nicolas Mailhot
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-16 09:11 EST by Mamoru TASAKA
Modified: 2009-02-16 14:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 14:58:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2009-02-16 09:11:32 EST
Description of problem:
See:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1130220
http://koji.fedoraproject.org/koji/taskinfo?taskID=1130229

The latter one has a lot of Provides:font(bar) in build.log, while
the former does not have any.
This is because in /usr/lib/rpm/fontconfig.prov $fcquery
aborts immediately if fontconfig is not installed (also
see "root.log"s)

Since
- For packages not related to fonts, "BR: fontconfig" is not
  needed
- Current font packaging guidelines "suggests" to include
  "BR: fontpackages-devel" (I don't know if this is "should" or
  "must" or just "is better")
adding "R: fontconfig" to fontpackages-devel seems the best
idea

Version-Release number of selected component (if applicable):
fontpackages-devel-1.18-1.fc11

How reproducible:
100%

Steps to Reproduce:
1. Rebuild srpm related to fonts which seems to match
   current font packaging guidelines with mockbuild
2. rpm -q --provides <the rebuild package>
  
Actual results:
None of the virtual Provides related to fonts can be seen
Comment 1 Nicolas Mailhot 2009-02-16 09:21:35 EST
I'll push a new fontpackage release this evening (CET). It's almost ready, I was just waiting to make sure Behdad and Panu didn't change their mind again (they pushed the rpm/fontconfig plumbing a few hours ago in koji)
Comment 2 Nicolas Mailhot 2009-02-16 13:41:35 EST
A new fontpackages has been pushed however it depends for other reasons on the new rpm that will be pushed koji-side tomorrow

Feel free to re-start the build as soon as this new rpm is deployed on the builders (if I miss it)

http://koji.fedoraproject.org/koji/getfile?taskID=1131126&name=srpm.log
Comment 3 Nicolas Mailhot 2009-02-16 14:58:07 EST
Oh, well, I can't wait. Pushed a band-aid

https://bugzilla.redhat.com/show_bug.cgi?id=485702

Just don't try to use the templates in there before koji is updated.

Note You need to log in before you can comment on or make changes to this bug.