Bug 485712 - man pages omit few options
man pages omit few options
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: coreutils (Show other bugs)
4.8
All Linux
medium Severity medium
: rc
: ---
Assigned To: Ondrej Vasik
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-16 09:53 EST by Petr Sklenar
Modified: 2009-05-18 16:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:07:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2009-02-16 09:53:24 EST
Description of problem:
There is few man pages discrepancy.
1.

csplit -q not documented
.qa.[root@x86-64-4as-m1 coreutils]# csplit README.txt "/=== */" {1} -q
.qa.[root@x86-64-4as-m1 coreutils]# csplit README.txt "/=== */" {1}
183
145
444
###############
2.
date 
not documented:
       --rfc-822
        --uct
        -I
I has same feature like:
--rfc-2822
--utc
--iso-8601
##############
3.
df  -- not documented options, but works:

df -F fstype
$ df -F ext3
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                      15643032   7012628   7835780  48% /
/dev/dasda1              99168     14700     79352  16% /boot
############
4.
df -m --kilobytes
# output in KB
df -m --megabytes
# output in MB


##############
5.
/usr/bin/du
	--kilobytes
	--megabytes
	-m


###############
6.
touch --file 
^not documented, same as -r, --reference=FILE-r

###############
uname
Man page OMITS 2 supported option(s):
        --release
        --sysname


###########
7.
$ nl tps.log --first-page=1
nl: unrecognized option `--first-page=1'
Try `nl --help' for more information.

man and --help contains fist-page
-v, --first-page=NUMBER         first line number on each logical page

############
8.
od
--string seems like unsupported

od --strings=10
^ it seems not working, on rhel5 it is not in man pages 

###########
9.
# sha1sum --string ahoj
edb433bdd7c13851c7c68cb31a5acf33a80cd2cc  "ahoj"

Version-Release number of selected component (if applicable):
coreutils-5.2.1-34.el4.x86_64

How reproducible:
always

  
Actual results:
some omitting

Expected results:
man page with all supported options

Additional info:
Comment 1 Petr Sklenar 2009-02-16 09:57:44 EST
ad 4 and 5: 
not documented options, but works
Comment 3 Ondrej Vasik 2009-02-16 12:12:04 EST
Just to track progress:
1) was already documented in info pages, but no harm to document it in man page as well
2) -I was in manpage (but as -ITIMESPEC) - so splitted to -I TIMESPEC - better readable form. --uct and --rfc-822 are aliases for --utc (--universal) and --rfc-2822 and are documented in info documentation - will not add those to man pages - as it is breaking --help indendation.
Comment 4 Ondrej Vasik 2009-02-16 12:28:10 EST
3) intentionally undocumented - it has same functionality as -t ( -F is used and kept just for compatibility with Solaris)

4) --kilobytes deprecated, removed from upstream, will not document that option
   -m / --megabytes is obsolescent (even in RHEL-4 sources), 
         maybe should be documented with warning about being obsolete

5) same as #4, but it seems that -m option will be kept at least for a while (just megabytes option deprecated with warning about removal and suggestion for usage of short one)
Comment 5 Ondrej Vasik 2009-02-17 07:42:21 EST
6) intentionally undocumented, phase out, --reference is full replacement
7) correct option should be --starting-line-number=NUMBER ... will fix that.
Comment 6 Ondrej Vasik 2009-02-17 08:01:07 EST
8) option which should work is --strings - and seems to be documented (and working) in RHEL-4 and RHEL-5

9) deprecated (and removed by upstream) - will keep it undocumented.
Comment 12 errata-xmlrpc 2009-05-18 16:07:26 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0959.html

Note You need to log in before you can comment on or make changes to this bug.