Bug 485755 - Taskomatic traceback after satsyncing on new install
Taskomatic traceback after satsyncing on new install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Michael Mráka
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-02-16 12:55 EST by Justin Sherrill
Modified: 2009-09-10 16:33 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:33:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2009-02-16 12:55:14 EST
1.  install satellite from iso
2.  sat sync one or more base channels.
3.  wait ~ 5 minutes
4.  Look in /var/log/rhn/rhn_taskomatic.log

You will see:

INFO   | jvm 1    | 2009/02/16 12:40:00 | 2009-02-16 12:40:00,149 [Thread-8330] ERROR com.redhat.rhn.manager.errata.cache.UpdateErrataCacheCommand - Problem updating cache for servers in channel
INFO   | jvm 1    | 2009/02/16 12:40:00 | com.redhat.rhn.common.db.WrappedSQLException: ORA-00911: invalid character
INFO   | jvm 1    | 2009/02/16 12:40:00 | 
INFO   | jvm 1    | 2009/02/16 12:40:00 | 	at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:112)
INFO   | jvm 1    | 2009/02/16 12:40:00 | 	at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:331)
INFO   | jvm 1    | 2009/02/16 12:40:00 | 	at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:288)
INFO   | jvm 1    | 2009/02/16 12:40:00 | 	at oracle.jdbc.driver.T4C8Oall.receive(T4C8Oall.java:745)
INFO   | jvm 1    | 2009/02/16 12:40:00 | 	at oracle.jdbc.driver.T4CPreparedStatement.doOall8(T4CPreparedStatement.java:219)
INFO   | jvm 1    | 2009/02/16 12:40:00 | 	at oracle.jdbc.driver.T4CPreparedStatement.executeForRows(T4CPreparedStatement.java:970)
INFO   | jvm 1    | 2009/02/16 12:40:00 | 	at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1190)
INFO   | jvm 1    | 2009/02/16 12:40:00 | 	at oracle.jdbc.driver.OraclePreparedStatement.executeInternal(OraclePreparedStatement.java:3370)
INFO   | jvm 1    | 2009/02/16 12:40:00 | 	at oracle.jdbc.driver.OraclePreparedStatement.execute(OraclePreparedStatement.java:3476)
INFO   | jvm 1    | 2009/02/16 12:40:00 | 	at com.mchange.v2.c3p0.impl.NewProxyPreparedStatement.execute(NewProxyPreparedStatement.java:651)
INFO   | jvm 1    | 2009/02/16 12:40:00 | 	at com.redhat.rhn.common.db.NamedPreparedStatement.execute(NamedPreparedStatement.java:137)
INFO   | jvm 1    | 2009/02/16 12:40:00 | 	at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:454)
INFO   | jvm 1    | 2009/02/16 12:40:00 | 	at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:431)
INFO   | jvm 1    | 2009/02/16 12:40:00 | 	at com.redhat.rhn.common.db.datasource.CachedStatement.executeUpdate(CachedStatement.java:269)
INFO   | jvm 1    | 2009/02/16 12:40:00 | 	at com.redhat.rhn.common.db.datasource.WriteMode.executeUpdate(WriteMode.java:33)
INFO   | jvm 1    | 2009/02/16 12:40:00 | 	at com.redhat.rhn.manager.errata.cache.ErrataCacheManager.updateErrataAndPackageCacheForChannel(ErrataCacheManager.java:415)
INFO   | jvm 1    | 2009/02/16 12:40:00 | 	at com.redhat.rhn.manager.errata.cache.UpdateErrataCacheCommand.updateErrataCacheForChannel(UpdateErrataCacheCommand.java:173)
INFO   | jvm 1    | 2009/02/16 12:40:00 | 	at com.redhat.rhn.taskomatic.task.errata.ErrataCacheWorker.run(ErrataCacheWorker.java:77)
INFO   | jvm 1    | 2009/02/16 12:40:00 | 	at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Worker.run(PooledExecutor.java:748)
INFO   | jvm 1    | 2009/02/16 12:40:00 | 	at java.lang.Thread.run(Thread.java:735)
INFO   | jvm 1    | 2009/02/16 12:40:00 | Caused by: 
INFO   | jvm 1    | 2009/02/16 12:40:00 | java.sql.SQLException: ORA-00911: invalid character
INFO   | jvm 1    | 2009/02/16 12:40:00 | 
INFO   | jvm 1    | 2009/02/16 12:40:00 | 	... 20 more
Comment 1 Justin Sherrill 2009-02-16 13:03:26 EST
commit	ff5f0f910e468688c2b43fcb72242dca37e2fdfa
tree	6689d4916b2b3905a8dacedacc3c0e1badaa3003	tree | snapshot
parent	58ff30fe861c975eb6f8f9ac8aa8466b0af47611	commit | diff
Comment 2 Michael Mráka 2009-04-10 08:57:02 EDT
Verified. Satellite-5.3.0-RHEL4-re20090403.2-i386


# egrep 'ORA-00911|Problem updating cache for servers in channel' /var/log/rhn/rhn_taskomatic_daemon.log
<on output>
Comment 3 Jan Pazdziora 2009-09-07 05:01:46 EDT
Stage validated with Satellite-5.3.0-RHEL5-re20090820.1:

[root@xen62 ~]# egrep 'ORA-00911|Problem updating cache for servers in channel' /var/log/rhn/rhn_taskomatic_daemon.log 
[root@xen62 ~]# 

Moving to RELEASE_PENDING.
Comment 4 Brandon Perkins 2009-09-10 16:33:16 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.