Bug 485798 - Switch of the kickstart virtualization type Paravirtualized-Guest changes the partitioning layout
Switch of the kickstart virtualization type Paravirtualized-Guest changes the...
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Virtualization (Show other bugs)
520
All Linux
low Severity medium
: ---
: ---
Assigned To: Devan Goodwin
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-16 15:12 EST by Stanislav Polasek
Modified: 2009-02-19 14:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-19 14:03:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stanislav Polasek 2009-02-16 15:12:55 EST
Description of problem:
Switch of the kickstart virtualization type to Paravirtualized-Guest changes the partitioning layout

Version-Release number of selected component (if applicable):
5.2

How reproducible:
Always

Steps to Reproduce:
1. clone some kickstart of a non-virtualized system with a specific patitioning layout
2. change the virtualization type to Paravirtualized-Guest
3. check the layout
  
Actual results:
Layout changes to a "predefined type".

Expected results:
Layout is kept.

Additional info:
Should the switch of the virtualization type really influence partitioning? Shouldn't the two kickstart sections be independent? Let's say I want to migrate system to the virtual environment. I have the kickstart, so I should just clone it, change the virtualization type and go. Why the hassle with the layout changing independently, in the background?
Comment 2 Devan Goodwin 2009-02-19 12:44:54 EST
As far as I know we are not using cobblers partitioning template and still specify it ourselves.

In spacewalk 0.4 for a physical host or fully virtualized guest the default partition info looks like:

clearpart --all
part /boot --fstype=ext3 --size=200
part pv.01 --size=1000 --grow
part swap --size=1000   --maxsize=2000
volgroup myvg pv.01
logvol / --vgname=myvg --name=rootvol --size=1000 --grow


Changing to Xen para-virt results in:

clearpart --all
part /boot --fstype ext3 --size=100 --ondisk=xvda
part pv.00 --size=0 --grow --ondisk=xvda
volgroup VolGroup00 --pesize=32768 pv.00
logvol / --fstype ext3 --name=LogVol00 --vgname=VolGroup00 --size=1024 --grow
logvol swap --fstype swap --name=LogVol01 --vgname=VolGroup00 --size=272 --grow --maxsize=544

The major difference here is the use of xvda, the other differences were specified before my time but I believe we done with para-virtualized guests in mind.

Note that on the kickstart details page where you can change the virtualization type for your profile the following message is displayed beneath the dropdown:

"NOTE: Changing the Virtualization Type may require changes to the kickstart profile's bootloader and partition options, potentially overwriting user customizations. Please visit the Partitioning tab to verify the new settings."

Changing the virtualization type to/from a combination that does not involve Xen Para-Virt (in Spacewalk and 5.3 there will be new options) should not result in any changes to the partition table. (though I am unable to verify this as it's blocked by another bug currently)

IMO this is by design, clarified when changing the virt type, and thus not a bug.
Comment 4 Clifford Perry 2009-02-19 14:03:02 EST
I agree with the general statement that this is working as designed, and Devan helped to clarify that a message is displayed in the interface to make the user aware, before making the change. 

Going to close this out as not a bug. 

Regards,
Clifford.

Note You need to log in before you can comment on or make changes to this bug.