Bug 485848 - konqueror proxy authentication regression with kde4.2
konqueror proxy authentication regression with kde4.2
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
10
i386 Linux
low Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-16 19:19 EST by Mike Pope
Modified: 2009-04-27 13:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-27 13:55:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 184588 None None None Never

  None (edit)
Description Mike Pope 2009-02-16 19:19:58 EST
Description of problem:

Since "upgrading" to kde 4.2 konqueror no longer handles the NTLM challenge from the corporate proxy server, preventing all external web access.
Akregator is likewise borked.  This is a serious regression from the last kde 4.1 package.

Version-Release number of selected component (if applicable):
kdebase-4.2.0-2.fc10.i386

How reproducible:
Attempt to access any non-local URL with konqueror.

Actual results:

Proxy replies with "407 Authentication Required", and konqueror stops there.
I can provide tcpdump output if it helps.

Expected results:

On receipt of the 407 konqueror should try to find a suitable username/password in an available wallet or prompt the user for such, and retry with that, satisfying the proxy and allowing the connection to proceed.

Additional info:

The proxy is specified with "Configure - Konqueror/Proxy/Manual specify the proxy settings", which have been checked and verified to work with firefox, same as they did before the upgrade.  However using the auto-proxy url produces the same breakage.

I have tried clearing kwallet, reinitializing with known good passwords, restarting etc, to no effect.  I have cleared every cache I can find.
Comment 1 Rex Dieter 2009-02-16 20:24:13 EST
Best to report to bugs.kde.org.  That's the best way to get upstream developer attention.
Comment 2 Steven M. Parrish 2009-03-16 20:29:28 EDT
Thank you for the bug report.  This issue needs to be addressed by the upstream developers.  Please submit a report at http://bugs.kde.org. You are requested to add the bugzilla link here for tracking purposes. Please make sure the bug isn't already in the upstream bug tracker before filing it.
Comment 3 Mike Pope 2009-03-17 19:19:34 EDT
Reported as https://bugs.kde.org/show_bug.cgi?id=184588, where it is claimed to be fixed in KDE 4.2.1.  Any chance of an update for F10?  This is pretty debilitating to those cursed with corporate firewalls.
Comment 4 Kevin Kofler 2009-03-17 19:28:22 EDT
4.2.1 has already been pushed as an update for Fedora 10. It went out to the stable updates on Monday evening. Does it fix the issue for you?
Comment 5 Mike Pope 2009-03-17 20:14:55 EDT
Good to hear, but the local mirrors are not that quick.  I will report back when I have the packages.
Comment 6 Steven M. Parrish 2009-04-27 13:55:12 EDT
Its been more than 30days since last update going to close as WORKSFORME. Please reopen if the issue returns.

Note You need to log in before you can comment on or make changes to this bug.