Bug 485952 - "Edit Attributes" page submit and cancel buttons don't leave the page
"Edit Attributes" page submit and cancel buttons don't leave the page
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: cumin (Show other bugs)
1.1
All Linux
urgent Severity urgent
: 1.1.1
: ---
Assigned To: Ernie
Jan Sarenik
:
: 476811 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-17 11:58 EST by Jeff Needle
Modified: 2009-04-21 12:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-21 12:16:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Needle 2009-02-17 11:58:30 EST
cumin-0.1.3109-1.el5.noarch on a RHEL5.3 box

Trying to modify the attributes of a running grid job with "Edit Attributes", I notice that the Submit and Cancel buttons don't leave the page.  The attributes are changed as expected, so this is just a minor annoyance.

These appear in the Error Console (Firefox 3.0.6 on F10)

Warning: variable elems redeclares argument
Source File: http://<mynode>:45672/resource?name=wooly.js
Line: 120, Column: 20
Source Code:
                var elems = elem.getElementsByTagName(child); 

Warning: variable node redeclares argument
Source File: http://<mynode>:45672/resource?name=wooly.js
Line: 147, Column: 12
Source Code:
        var node = result.iterateNext(); 

Warning: anonymous function does not always return a value
Source File: http://<mynode>:45672/resource?name=wooly.js
Line: 313, Column: 12
Source Code:
        }
Comment 1 Ernie 2009-02-24 14:27:08 EST
*** Bug 476811 has been marked as a duplicate of this bug. ***
Comment 2 Ernie 2009-02-24 14:32:38 EST
Fixed (I hope) in cumin 3130.
It appears that different OS releases handle the http header REFERRER differently.
Submit and Cancel should now return to the View job Ads page.
Comment 3 Jan Sarenik 2009-03-02 04:42:00 EST
Still does not work for me in cumin-0.1.3120-1.el5

Strangely enough, it works for completed or removed
job, but not when viewing properties of a running one.

FYI, accessing properties (clicking on job ID) of
any completed/removed job is noticably slower
compared to doing the same for running/idle job.
Comment 4 Ernie 2009-03-02 08:24:36 EST
Please try with cumin version 3130. That is the version I made the changes in.
Comment 5 Jan Sarenik 2009-03-05 03:42:31 EST
On cumin-0.1.3137-1.el5 I am getting APPLICATION ERROR
after clicking on any of "Submit" or "Cancel".

When I run Cumin on a console with
   cumin --debug --addr 192.168.1.8 --log-level debug
I am unable to find there any sensible output
regarding the error.
Comment 6 Ernie 2009-03-05 16:27:41 EST
Fixed the APPLICATION ERROR in cumin version 3141.
Comment 7 Jan Sarenik 2009-03-13 04:35:07 EDT
Please build a new cumin package so I can test it. Thanks.
Comment 9 Jan Sarenik 2009-03-18 07:43:59 EDT
Working as expected on cumin-0.1.3160-1.el5
Thanks!
Comment 11 errata-xmlrpc 2009-04-21 12:16:19 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-0434.html

Note You need to log in before you can comment on or make changes to this bug.