Bug 485953 - Display corruption on ATI ES1000
Display corruption on ATI ES1000
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
All Linux
high Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-17 12:02 EST by Evan McNabb
Modified: 2010-04-29 15:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-29 15:07:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of corruption (953.90 KB, image/png)
2009-02-17 12:02 EST, Evan McNabb
no flags Details
Xorg.log from system (55.24 KB, text/plain)
2009-02-17 12:03 EST, Evan McNabb
no flags Details
dmesg from Rawhide (61.73 KB, text/plain)
2009-02-23 12:14 EST, Evan McNabb
no flags Details
dmesg from RHEL5 (27.49 KB, text/plain)
2009-02-23 12:15 EST, Evan McNabb
no flags Details
Xorg.0.log from RHEL5 (61.97 KB, text/plain)
2009-02-23 12:16 EST, Evan McNabb
no flags Details
dmesg for kernel-2.6.29-0.215.rc7.fc11 (61.08 KB, text/plain)
2009-03-09 10:56 EDT, Evan McNabb
no flags Details
Xorg.0.log from xorg-x11-drv-ati-6.11.0-5.fc11.x86_64 (105.42 KB, text/plain)
2009-03-09 10:58 EDT, Evan McNabb
no flags Details
Xorg.log without nomodeset (slow X) (64.88 KB, application/octet-stream)
2009-08-07 08:25 EDT, Kari Hautio
no flags Details
Xorg.log with nomodeset (88.96 KB, application/octet-stream)
2009-08-07 08:26 EDT, Kari Hautio
no flags Details
sosreport from DL360 G5 (510.44 KB, application/x-bzip)
2009-08-07 08:27 EDT, Kari Hautio
no flags Details

  None (edit)
Description Evan McNabb 2009-02-17 12:02:25 EST
Created attachment 332250 [details]
Screenshot of corruption

Description of problem:

This system has a built in ATI ES1000. During install, Anaconda/X work as expected. However, there is serious screen corruption once the system boots. 

I'm attaching a screen shot which shows the problem. If the mouse is moved around the random parts of the screen experience corruption and other parts refresh correctly.

Version-Release number of selected component (if applicable):

This occurs on both F10 and the latest Rawhide (20090217):
kernel-2.6.29-0.124.rc5.fc11.x86_64
xorg-x11-drv-ati-6.10.0-3.fc11.x86_64

I installed RHEL5 which worked as expected.

How reproducible:
Every time.

Steps to Reproduce:
1. Install system
2. Boot and make no changes to X configuration (no xorg.conf exists)
  
Actual results:
Scrambled display

Expected results:
Properly display screen
Comment 1 Evan McNabb 2009-02-17 12:03:32 EST
Created attachment 332251 [details]
Xorg.log from system
Comment 2 François Cami 2009-02-20 14:28:47 EST
Evan,

Could you add dmesg as uncompressed text/plain attachment to this bug report ?

Thank you

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 François Cami 2009-02-22 10:15:24 EST
dmesg and Xorg.0.log from RHEL5 may help too, if this is at all possible.

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Evan McNabb 2009-02-23 12:14:45 EST
Created attachment 332948 [details]
dmesg from Rawhide
Comment 5 Evan McNabb 2009-02-23 12:15:42 EST
Created attachment 332949 [details]
dmesg from RHEL5
Comment 6 Evan McNabb 2009-02-23 12:16:31 EST
Created attachment 332950 [details]
Xorg.0.log from RHEL5
Comment 7 Evan McNabb 2009-02-23 12:18:32 EST
Here is the data you requested - sorry for the delay.
Comment 8 Dave Airlie 2009-03-07 06:28:12 EST
please retry with the latest -ati in rawhide. It contains some RN50 fixes from upstream.
Comment 9 Evan McNabb 2009-03-09 10:53:55 EDT
I tried out rawhide-20090309 (2.6.29-0.215.rc7.fc11.x86_64, xorg-x11-drv-ati-6.11.0-5.fc11.x86_64) and it has the same display corruption. I'll attach updated dmesg and Xorg logs in case that helps.
Comment 10 Evan McNabb 2009-03-09 10:56:50 EDT
Created attachment 334531 [details]
dmesg for kernel-2.6.29-0.215.rc7.fc11
Comment 11 Evan McNabb 2009-03-09 10:58:02 EDT
Created attachment 334533 [details]
Xorg.0.log from xorg-x11-drv-ati-6.11.0-5.fc11.x86_64
Comment 12 Bug Zapper 2009-06-09 07:27:42 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Kari Hautio 2009-08-07 08:21:59 EDT
I have a somewhat similar problem so decided to update this bug instead of creating a new one.

Basically I don't see screen corruption but the X is just horribly slow, ie. mouse movement will be visible only after a second or so. The slowness makes X completely unusable.

The problem goes away by disabling kernel mode setting by "nomodeset".

Attaching Xorg.log with and without nomodeset along with sosreport.
Comment 14 Kari Hautio 2009-08-07 08:25:56 EDT
Created attachment 356642 [details]
Xorg.log without nomodeset (slow X)
Comment 15 Kari Hautio 2009-08-07 08:26:45 EDT
Created attachment 356644 [details]
Xorg.log with nomodeset
Comment 16 Kari Hautio 2009-08-07 08:27:47 EDT
Created attachment 356645 [details]
sosreport from DL360 G5
Comment 17 jfisher.bug 2009-08-10 03:45:02 EDT
I have the same problem with ATI ES1000 on a HP DL380G6 with Fedora 11. I am running kernel-PAE-2.6.29.6-217.2.3.fc11.i686, xorg-x11-drv-ati-6.12.2-14.fc11.i586.
Kickstart Installation does not show a screen. After Installation the system is to slow to use it.
Booting with 'nomodeset' resolves the problem.
Comment 18 Matěj Cepl 2009-11-05 13:22:08 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 19 Evan McNabb 2009-11-16 15:28:40 EST
I tried the F12 live CD and still see the display corruption. Booting with nomodeset resolves the problem.
Comment 20 Bug Zapper 2010-04-27 09:00:13 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 21 Evan McNabb 2010-04-29 15:07:28 EDT
This now works correctly for me on rawhide and RHEL6 beta so I'll go ahead and close it. Feel free to re-open or created a new BZ if needed.

Note You need to log in before you can comment on or make changes to this bug.