Bug 485977 - Exception when cancelling 'write to disk' - request has no attr 'drive'
Exception when cancelling 'write to disk' - request has no attr 'drive'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 486344 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-17 13:59 EST by Evan McNabb
Modified: 2009-02-20 16:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-20 16:39:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dump (106.45 KB, text/plain)
2009-02-17 13:59 EST, Evan McNabb
no flags Details
Second Anaconda dump (similar, but not exact traceback) (113.73 KB, text/plain)
2009-02-17 14:01 EST, Evan McNabb
no flags Details

  None (edit)
Description Evan McNabb 2009-02-17 13:59:59 EST
Created attachment 332275 [details]
Anaconda dump

Description of problem:

Anaconda crashes when the 'Go back' button is clicked at the "Writing partitioning to disk" screen. It only occurs if the partitioning review screen was selected. I'm including two backtraces that have been produced (they are similar but not identical).

Version-Release number of selected component (if applicable):
Rawhide 20090216

How reproducible:
Every time

Steps to Reproduce:
1. Start installation.
2. On partitioning screen select "Replace existing Linux system" and "Review and modify partitioning layout". Click next.
3. On partitioning review screen do not modify anything. Click next.
4. On "Writing partitioning to disk" screen click "Go back"
5. Exception occurs.
  
Actual results:
Anaconda throws traceback.

Expected results:
It should gracefully return to the previous screen.
Comment 1 Evan McNabb 2009-02-17 14:01:02 EST
Created attachment 332276 [details]
Second Anaconda dump (similar, but not exact traceback)
Comment 2 Chris Lumens 2009-02-19 11:13:48 EST
*** Bug 486344 has been marked as a duplicate of this bug. ***
Comment 3 Chris Lumens 2009-02-20 16:39:47 EST
This should be fixed in the next build of anaconda.  There may be more partitioning errors lurking, however.

Note You need to log in before you can comment on or make changes to this bug.