Bug 485997 - openmpi's mpitests-IMB-EXT fails
openmpi's mpitests-IMB-EXT fails
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openmpi (Show other bugs)
4.8
All Linux
medium Severity medium
: rc
: ---
Assigned To: Doug Ledford
Red Hat Kernel QE team
:
Depends On: 472461
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-17 15:38 EST by Gurhan Ozen
Modified: 2013-11-03 20:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 472461
Environment:
Last Closed: 2009-09-13 16:03:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gurhan Ozen 2009-02-17 15:38:53 EST
This issue exists on 4.8 too. 

+++ This bug was initially created as a clone of Bug #472461 +++

Description of problem:
openmpi's mpitests-IMB-EXT fails as shown below:

[dhcp71-141.rhts.bos.redhat.com:05465] *** An error occurred in MPI_Win_free
[dhcp71-141.rhts.bos.redhat.com:05465] *** on win 
[dhcp71-141.rhts.bos.redhat.com:05465] *** MPI_ERR_RMA_SYNC: error while executing rma sync
[dhcp71-141.rhts.bos.redhat.com:05465] *** MPI_ERRORS_ARE_FATAL (goodbye)
[dhcp71-142.rhts.bos.redhat.com:04387] *** An error occurred in MPI_Win_free
[dhcp71-142.rhts.bos.redhat.com:04387] *** on win 
[dhcp71-142.rhts.bos.redhat.com:04387] *** MPI_ERR_RMA_SYNC: error while executing rma sync
[dhcp71-142.rhts.bos.redhat.com:04387] *** MPI_ERRORS_ARE_FATAL (goodbye)

This happens when it's run over IB fabric. When run over tcp, it just stalls. Was able to reproduce this both 32-bit and 64-bit.

Version-Release number of selected component (if applicable):
mpitests-openmpi-3.0-2.el5

How reproducible:
Everytime.
Comment 1 Doug Ledford 2009-08-24 09:43:43 EDT
Note: I do not intend to update openmpi in rhel4.9.  However, this bug is
against an mpitests error on openmpi.  The problem could actually lie with
either the mpitests package (which doesn't have a bugzilla component or else I
would switch it over) or the openmpi package.  If it turns out to be with
mpitests, I'm planning on updating mpitests for another bug and will get this
at the same time.  If the issue turns out to be with openmpi, then this will
likely get closed as WONTFIX.
Comment 2 Doug Ledford 2009-09-13 16:03:35 EDT
This appears to be an openmpi bug, and since openmpi isn't on the rhel4.9 package list, this is being closed out as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.