Bug 486039 - RHEL4 gnuplot doesn't do PNG as advertised
RHEL4 gnuplot doesn't do PNG as advertised
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gnuplot (Show other bugs)
4.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Ivana Varekova
BaseOS QE
:
: 209428 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-17 18:28 EST by Bryan Mason
Modified: 2010-10-23 03:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 238053
Environment:
Last Closed: 2009-05-18 16:36:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan Mason 2009-02-17 18:28:57 EST
+++ This bug was initially created as a clone of Bug #238053 +++

Description of Problem:

    gnuplot does not properly support the size parameter when using
    the png terminal type.

        gnuplot> set terminal png size 1414,1000
        Terminal type set to 'png'
                             ^
                expecting: {small, medium, large},[no]transparent, or 
        {monochrome, gray, color, [xRRGGBB] }
        gnuplot> set output "test.png"
        gnuplot> splot sin(x+y)

    This test.png file will be created but at the default 640x480 size.  

Version-Release number of selected component (if applicable):

    gnuplot-4.0.0-4

How reproducible:

    100%

Steps to Reproduce:

    # gnuplot
    gnuplot> set terminal png size 1414,1000
    gnuplot> set output "test.png"
    gnuplot> splot sin(x+y)
  
Actual results:

    set command produces error:

       gnuplot> set terminal png size 1414,1000
       Terminal type set to 'png'
                         ^
                expecting: {small, medium, large},[no]transparent, or 
       {monochrome, gray, color, [xRRGGBB] }

Expected results:

    'set' command succeeds and output file is at 1414x1000 size

Additional info:

    Fixed in RHEL 5 by Errata 
   http://rhn.redhat.com/errata/RHBA-2008-0614.html
Comment 6 Ludek Smid 2009-02-19 08:49:01 EST
*** Bug 209428 has been marked as a duplicate of this bug. ***
Comment 14 errata-xmlrpc 2009-05-18 16:36:52 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1027.html

Note You need to log in before you can comment on or make changes to this bug.