Bug 486041 - PS3: anaconda fails due to lack of memory
PS3: anaconda fails due to lack of memory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
ppc64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-17 18:55 EST by Geoff Levand
Modified: 2009-02-25 00:38 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-25 00:38:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geoff Levand 2009-02-17 18:55:35 EST
Description of problem:

On PS3 anaconda fails due to lack of memory.

With the current rawhide (Fedora 11) kernel the PS3 hotplug memory add fails and the system boots with just the 128 MiB of boot mem.

Additional info:

On Feb 17, 2009, two patches that fix this problem were merged to linux-2.6.29-rc6:

powerpc/mm: Fix numa reserve bootmem page selection
Commit 06eccea6c34e00c8fedce49229ed35fa84619fb7
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=06eccea6c34e00c8fedce49229ed35fa84619fb7

powerpc/ps3: Move ps3_mm_add_memory to device_initcall
Commit 0047656e2a97d4452dd7df9e52591a7afe21a263
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=0047656e2a97d4452dd7df9e52591a7afe21a263

-Geoff
Comment 1 Kyle McMartin 2009-02-25 00:38:45 EST
These are (obviously) in the latest rawhide kernel, so they shouldn't cause you trouble in the future. :)

cheers, kyle

Note You need to log in before you can comment on or make changes to this bug.