This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 486054 - Proxy config in rhn_web.conf defaulting to spacewalk value
Proxy config in rhn_web.conf defaulting to spacewalk value
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Shannon Hughes
Steve Salevan
:
Depends On:
Blocks: 456999 463876 482926 485985
  Show dependency treegraph
 
Reported: 2009-02-17 20:52 EST by Shannon Hughes
Modified: 2009-09-10 10:37 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 10:37:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shannon Hughes 2009-02-17 20:52:49 EST
Description of problem:

the config web.subscribe_proxy_channel is defaulting to 0 for satellite isos. this is the spacewalk default. we need to have this config default to 1 for satellite isos otherwise the proxy installer will not subscribe the system to the proxy channel and won't be able to find the required package spacewalk-proxy-management.
Comment 1 Shannon Hughes 2009-02-17 21:07:32 EST
do we have separate rhn_web.conf files for spacewalk vs satellite. I think the subscribe_proxy_channel should automatically be set to 1 for satellite installs.
Comment 2 Jesus M. Rodriguez 2009-02-17 22:02:44 EST
We need to modify the Setup to set it to 1 when installing Satellite. We do *NOT* have separate rhn_web.conf's we should override it in rhn.conf during installation.
Comment 3 Shannon Hughes 2009-02-18 15:35:48 EST
submitted changes for this in the satellite git repo.
Comment 4 Jesus M. Rodriguez 2009-02-27 15:33:59 EST
fixed in 8c9d447dfdb2ec7e1cad49b8a26743823c94205b
Comment 5 Miroslav Suchý 2009-03-02 04:28:00 EST
Commit 8c9d447dfdb2ec7e1cad49b8a26743823c94205b not found. Did you forget to push it? Moving back to ASSIGNED.

Anyway the subscribe_proxy_channel should be set to 1 by default in:
 satellite-branding/setup/defaults.d/satellite-branding.conf
which should override the default rhn_web.conf
So question is how it is possible that you see web.subscribe_proxy_channel as zero?
Comment 6 Jesus M. Rodriguez 2009-03-02 09:28:48 EST
the config option needs to be added to the list in spacewalk/setup/bin/spacewalk-setup

I'm not sure I like this part because it seems rather redundant to have to enter it twice.
Comment 7 Jesus M. Rodriguez 2009-03-04 13:33:14 EST
fixed in 8c9d447dfdb2ec7e1cad49b8a26743823c94205b
Comment 8 Steve Salevan 2009-03-10 13:06:12 EDT
Verified presence of spacewalk-proxy-management package in rhn-tools channels, noted the following value in /usr/share/spacewalk/setup/defaults.d/satellite-branding.conf:

web.subscribe_proxy_channel = 1

This bug is VERIFIED on 530-re20090306.2.
Comment 10 Brandon Perkins 2009-09-10 10:37:36 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1433.html

Note You need to log in before you can comment on or make changes to this bug.