Bug 486081 - No anti-aliased fonts after KDE 4.2 upgrade (in most applications)
No anti-aliased fonts after KDE 4.2 upgrade (in most applications)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
9
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 03:18 EST by Nineth
Modified: 2009-02-21 06:20 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-21 06:20:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Terrible fonts (55.03 KB, image/png)
2009-02-18 03:18 EST, Nineth
no flags Details
/var/log/yum.log (30.86 KB, text/plain)
2009-02-21 00:14 EST, Nineth
no flags Details

  None (edit)
Description Nineth 2009-02-18 03:18:22 EST
Created attachment 332345 [details]
Terrible fonts

Description of problem:

After my latest yum update, most applications do not display any anti aliased 
fonts. The fonts are hard to look at and very difficult to work with; see attached screenshot. Some applications like konsole work fine. Most of the others including Firefox don't. Surprisingly, even 'System Settings', which I thought was Qt based doesn't display anti-aliased fonts.

Version-Release number of selected component (if applicable):

4.2.0-8.fc9

How reproducible:

Can reproduce always

Steps to Reproduce:
1. Start firefox
2. Start 'System Settings'
  
Actual results:

See attached screenshot


Expected results:

Really cool fonts that I've been used to in KDE 4.1



Additional info:
Comment 1 Kevin Kofler 2009-02-18 11:15:09 EST
That's strange, the app on the screenshot is Firefox which isn't even a KDE app.

Are you sure this was caused by the KDE 4.2 update and not some other update? What graphics hardware/driver are you using?
Comment 2 Rex Dieter 2009-02-18 11:18:42 EST
Also, mind including the relevant parts of /var/log/yum.log that include details about pkg updates between when things were working and not?
Comment 3 Nineth 2009-02-21 00:12:35 EST
I have the nVidia Quadro FX 570M with nVidia's latest driver installed (177.82). Everything was working fine before the KDE 4.2 update; I have no bulletproof guarantee that KDE 4.2 is responsible though. BTW, even KDE apps display the bad fonts now - konsole and 'System Settings' as well -- it's strange that I can't reproduce it always with konsole and 'System Settings', but always with firefox as far as I've used kde 4.2.

/var/log/yum.log is attached.
Comment 4 Nineth 2009-02-21 00:14:14 EST
Created attachment 332787 [details]
/var/log/yum.log
Comment 5 Kevin Kofler 2009-02-21 00:46:31 EST
Hmmm, the thing is, this seems to work for everybody else... You have a lot of third-party stuff on your system: there's the nvidia driver and then there's tons of IBM packages, some of which got updated at the same time as KDE according to your log. It is hard to pinpoint the source of the trouble, but I suspect either a bug in the nvidia driver or some third-party app screwing up your fontconfig settings.

Have you tried logging into GNOME? If non-KDE apps in GNOME also look broken, then I don't see how KDE is to blame. KDE almost certainly doesn't mess up global fontconfig settings, you wouldn't be the only one to complain if it did. ;-)
Comment 6 Nineth 2009-02-21 01:13:28 EST
I logged into GNOME. The fonts are bad there too, in fact worse, with all the GNOME desktop menus displaying fonts with no anti-aliasing. 

My nVidia driver has remained unchanged through the yum update and everything was fine earlier. What packages should I reinstall to reset fontconfig settings? I reinstalled fontconfig, but it didn't help. Thanks.
Comment 7 Nineth 2009-02-21 03:00:45 EST
There was .fonts.conf in my home dir. I deleted it and the problem is now gone. There is no longer .fonts.conf in my home dir;  don't know which application created it or messed it up.
Comment 8 Nineth 2009-02-21 04:59:05 EST
I think my .fonts.conf was generated by 'System Settings' from Appearance -> Fonts -> .... I remember changing some of my font sizes and a custom .fonts.conf was generated; it created the problem.
Comment 9 Kevin Kofler 2009-02-21 06:20:36 EST
User configuration issue, closing.

Note You need to log in before you can comment on or make changes to this bug.