Bug 486082 - pavucontrol doesn't start.
pavucontrol doesn't start.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pavucontrol (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
: 485840 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 04:27 EST by sangu
Modified: 2009-02-24 21:42 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 21:40:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2009-02-18 04:27:46 EST
Description of problem:
(gdb) r
Starting program: /usr/bin/pavucontrol 
[Thread debugging using libthread_db enabled]

Program received signal SIGSEGV, Segmentation fault.
0x00000038c5081040 in strlen () from /lib64/libc.so.6
(gdb) bt
#0  0x00000038c5081040 in strlen () from /lib64/libc.so.6
#1  0x00000037a0c3fc9c in Glib::ustring::operator=(char const*) ()
   from /usr/lib64/libglibmm-2.4.so.1
#2  0x000000000041351c in MainWindow::updateRole (this=0x7fffef35a240, 
    info=@0x7fffffffdbd0) at pavucontrol.cc:1426
#3  0x00007ffff628f1ae in ext_stream_restore_read_cb (pd=0x7fffeb157da0, 
    command=2, tag=9, t=0x7fffeb202190, userdata=0x7fffeb19abd0)
    at pulse/ext-stream-restore.c:143
#4  0x00007ffff591bc96 in run_action (pd=0x7fffeb157da0, r=0x7fffeb19ad40, 
    command=2, ts=0x7fffeb202190) at pulsecore/pdispatch.c:256
#5  0x00007ffff591bffb in pa_pdispatch_run (pd=0x7fffeb157da0, 
    packet=0x7fffeb18da40, creds=0x7fffeb1e9d00, userdata=0x7ffff0536410)
    at pulsecore/pdispatch.c:308
#6  0x00007ffff628a517 in pstream_packet_callback (p=0x7fffeb1e9bb0, 
    packet=0x7fffeb18da40, creds=0x7fffeb1e9d00, userdata=0x7ffff0536410)
    at pulse/context.c:329
#7  0x00007ffff5921eb2 in do_read (p=0x7fffeb1e9bb0) at pulsecore/pstream.c:816
#8  0x00007ffff591f4c1 in do_something (p=0x7fffeb1e9bb0)
    at pulsecore/pstream.c:184
#9  0x00007ffff591f6de in io_callback (io=0x7fffeb1e9b10, 
    userdata=0x7fffeb1e9bb0) at pulsecore/pstream.c:213
#10 0x00007ffff5909ee8 in callback (m=0x7ffff0539750, e=0x7fffeb1e9b60, fd=8, 
    f=3, userdata=0x7fffeb1e9b10) at pulsecore/iochannel.c:119
---Type <return> to continue, or q <return> to quit---
#11 0x00007ffff64c5c76 in dispatch_func (source=0x7ffff05396f0, callback=0, 
    userdata=0x0) at pulse/glib-mainloop.c:585
#12 0x00007ffff66ff12e in g_main_dispatch (context=<value optimized out>)
    at gmain.c:1814
#13 IA__g_main_context_dispatch (context=0x7ffff04a5730) at gmain.c:2367
#14 0x00007ffff6702888 in g_main_context_iterate (context=0x7ffff04a5730, 
    block=<value optimized out>, dispatch=<value optimized out>, 
    self=<value optimized out>) at gmain.c:2448
#15 0x00007ffff6702d25 in IA__g_main_loop_run (loop=0x7fffeb18bf10)
    at gmain.c:2656
#16 0x00007ffff7af79b7 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
#17 0x000000379cea8e1b in Gtk::Main::run(Gtk::Window&) ()
   from /usr/lib64/libgtkmm-2.4.so.1
#18 0x0000000000412910 in main (argc=1, argv=0x7fffffffe468)
    at pavucontrol.cc:2032


Version-Release number of selected component (if applicable):
0.9.7-3.fc10.x86_64

How reproducible:
always

Steps to Reproduce:
1. $ pavucontrol
2.
3.
  
Actual results:


Expected results:


Additional info:
pulseaudio-0.9.15-0.test2.fc11.x86_64
Comment 1 Fernando Atrio 2009-02-24 12:18:59 EST
This patch solves the issue for me (not sure if it makes any sense though).
It has to be applied to pavucontrol.cc:

<     eventRoleWidget->device = info.device;
---
>     //eventRoleWidget->device = info.device;
1967a1968
> 
1979a1981
> 

This is my smolt profile, http://www.smolts.org/client/show/pub_80e1585f-23f9-4188-9c10-39e2dd1426a8 


I hope this helps.
Comment 2 Fernando Atrio 2009-02-24 12:23:50 EST
I'm using pavucontrol-0.9.7-3.fc10.i386
Comment 3 Lennart Poettering 2009-02-24 21:40:51 EST
Fixed in pavucontrol-0.9.7-4 which is currently being built.
Comment 4 Lennart Poettering 2009-02-24 21:42:38 EST
*** Bug 485840 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.