Bug 486099 - profiler (opreport) fails on virtual host
profiler (opreport) fails on virtual host
Status: CLOSED DUPLICATE of bug 479739
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5.3
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Greg Nichols
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 07:24 EST by Martin Brinz
Modified: 2014-03-25 20:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-13 20:00:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Brinz 2009-02-18 07:24:17 EST
Description of problem:
with hts-5.3-15.el5 on a x86_64 architecture blade with CPU VT support (Nehalem) and RHEL5.3 the test plan foresees a test case called
profiler
which actually uses the commands
opcontrol
and
opreport
to profile the systems symbol and binary image summaries

The profiler test works well on the XEN system host (well with some error postings, which I've already seen in a different bug report, nevertheless the test itsself returns OK).
As soon as the same test is performed on a virtual machine of this blade running on top of the XEN system host (again RHEL5.3 with hts-5.3-15.el5) the
profiler
test will fail.
As can be seen from profiler.py the following commands get executed
opcontrol --start
opreport

On the XEN system host opreport will correctly collect the data and write it into /var/lib/oprofile/samples/current/...
on the virtual machine however opreport will fail with the error message

opreport error: No sample file found: try running opcontrol --dump
or specify a session containing sample files

In addition no subdirectories like {root} or {kern} are created within
/var/lib/oprofile/samples/current/
on the virtual host.

Any idea whether we can skip the profiler test for the virtual host HW certification or do you have a workaround for this?

Version-Release number of selected component (if applicable):
oprofile 0.9.3 (part of RHEL5.3 distribution)

How reproducible:
see above

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Rob Landry 2009-06-13 20:00:22 EDT
hts-5.3-17 includes and update which should no longer plan the profiler test in the guest.  Marking this as a duplicate of 479739 where this issue was addressed.

*** This bug has been marked as a duplicate of bug 479739 ***

Note You need to log in before you can comment on or make changes to this bug.