Bug 486100 - After removing kpowersave, can't change screen brightness with Fn keys
After removing kpowersave, can't change screen brightness with Fn keys
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 07:39 EST by Amit Shah
Modified: 2009-05-26 09:24 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-26 09:24:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 194166 None None None Never

  None (edit)
Description Amit Shah 2009-02-18 07:39:22 EST
Description of problem:
After the recent upgrade to 4.2 in F10, I had kpowersave, guidance-power-manager as well as the new powerdevil framework for managing the laptop battery. I removed kpowersave and guidance-power-manager and switched to powerdevil.

My laptop is a ThinkPad X200 with Intel graphics.

After removing kpowersave, however, my Fn+brightness keys stopped working. I can change the brightness from the battery plasmoid. tpb is also installed and it shows its brightness bar as well when the setting is changed from powerdevil.
Comment 1 Rex Dieter 2009-02-18 08:47:18 EST
Interesting, we've other reports from thinkpad users reporting Tn+brightness keys have *never* worked:
https://bugzilla.redhat.com/show_bug.cgi?id=475247

Maybe it was kpowersave's use-of/reliance on acpid for some functions?  (newer apps like guidance and powerdevil use hal exclusively)
Comment 2 Steven M. Parrish 2009-04-27 14:12:05 EDT
Keep this open, bump upstream or WONTFIX?
Comment 3 Steven M. Parrish 2009-05-26 09:24:24 EDT
Going to close this as UPSTREAM.  Since there is little the KDE-SIG can do
about this and other multimedia/laptop button issues we have to wait for
upstream to address this.

Note You need to log in before you can comment on or make changes to this bug.