Bug 486105 - file-5.00-2.fc11 fails to recognise a file (and makes rpmbuild fail)
file-5.00-2.fc11 fails to recognise a file (and makes rpmbuild fail)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: file (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Novotny
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 08:11 EST by Fabrice Bellet
Modified: 2009-02-23 10:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-23 10:40:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this file breaks file-5.00 (7.03 KB, application/octet-stream)
2009-02-18 08:33 EST, Fabrice Bellet
no flags Details
a patch for the crash (3.03 KB, patch)
2009-02-23 06:22 EST, Daniel Novotny
no flags Details | Diff

  None (edit)
Description Fabrice Bellet 2009-02-18 08:11:44 EST
Hi!

This bug is probably related to #485141. In rawhide, file fails to recognize a file from FlightGear-data. The error message from rpmbuild is :

Recognition of file "/builddir/build/BUILDROOT/FlightGear-data-1.9.0-1.fc11.i386
/usr/share/FlightGear/Aircraft/c172p/Models/Immat/Thumbs.db" failed: mode 100644
 Cannot read short stream (Invalid argument)

with file-4.26-4.fc10, this file was recognized as a Microsoft Office Document:
$ file /usr/share/FlightGear/Aircraft/c172p/Models/Immat/Thumbs.db
/usr/share/FlightGear/Aircraft/c172p/Models/Immat/Thumbs.db: Microsoft Office Document

(With the next mass rebuild of Fedora packages, file will be tested extensively, as it seems that packaged files, that make file return a non zero status, prevent a package from being rebuilt successfully)
Comment 1 Daniel Novotny 2009-02-18 08:26:01 EST
hello Fabrice, can you attach the Thumbs.db file?
thanks
Comment 2 Fabrice Bellet 2009-02-18 08:33:56 EST
Created attachment 332371 [details]
this file breaks file-5.00
Comment 3 Daniel Novotny 2009-02-23 06:22:01 EST
Created attachment 332921 [details]
a patch for the crash
Comment 4 Fabrice Bellet 2009-02-23 08:40:46 EST
it works for me. Thanks!
Comment 5 Daniel Novotny 2009-02-23 10:40:49 EST
fixed in file-5.00-3.fc11

Note You need to log in before you can comment on or make changes to this bug.