Bug 486115 - gparted crash with mount dvd on /dev/hdc
gparted crash with mount dvd on /dev/hdc
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: gparted (Show other bugs)
el5
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
ActualBug
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 09:42 EST by Martin Naď
Modified: 2010-12-22 13:42 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-22 13:42:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Naď 2009-02-18 09:42:01 EST
Description of problem:
gparted crash,with mount dvd (/dev/hdc), with this backtrace 

[root@Metallica Gordon]# gparted
======================
libparted : 1.8.1
======================
Unable to open /dev/hdc read-write (Systém souborů je pouze pro čtení).  /dev/hdc has been opened read-only.
Neoprávněný přístup do paměti (SIGSEGV)
[root@Metallica Gordon]#

with this 
Version-Release number of selected component (if applicable):
gparted-0.3.3-4.el5

How reproducible:
every time

Steps to Reproduce:
1.run gparted ,when dvd mounted
2.gparted crash
  
Actual results:
gparted crash, when mount dvd
Comment 1 Curtis Gedak 2009-10-20 17:06:53 EDT
Many improvements have been made to GParted and parted since version 0.3.3.  This problem should no longer occur with the most recent versions of GParted.  Currently the most recent release of GParted is 0.4.7.

To test with the most recently release, you can download and burn a live CD directly from the GParted site:
http://gparted.sourceforge.net/livecd.php
Comment 2 Mark Chappell 2010-10-17 02:01:10 EDT
Martin,

gparted in EPEL was updated earlier this year.  Are you still able to reproduce this error with the new version (gparted-0.4.8-1.el5)
Comment 3 Martin Naď 2010-12-22 13:42:23 EST
gparted-0.4.8-1.el5 work ok, dont crash on start.

Note You need to log in before you can comment on or make changes to this bug.