Bug 486123 - Kickstart install fails: KeyError 's'
Kickstart install fails: KeyError 's'
Status: CLOSED DUPLICATE of bug 485622
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 10:28 EST by Cole Robinson
Modified: 2009-02-18 11:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-18 11:45:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda bug report output (88.40 KB, text/plain)
2009-02-18 10:28 EST, Cole Robinson
no flags Details

  None (edit)
Description Cole Robinson 2009-02-18 10:28:27 EST
Created attachment 332388 [details]
Anaconda bug report output

From latest rawhide:

anaconda 11.5.0.19 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/autopart.py", line 75, in bootRequestCheck
    part = diskset.disks[drive].getPartitionByPath("/dev/%s" % req.device)
  File "/usr/lib/anaconda/autopart.py", line 1054, in doPartitioning
    ret = bootRequestCheck(req, diskset)
  File "/usr/lib/anaconda/autopart.py", line 1520, in doAutoPartition
    doPartitioning(diskset, partitions, doRefresh = 0)
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 226, in currentStep
    self.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1355, in setScreen
    (step, anaconda) = self.anaconda.dispatch.currentStep()
  File "/usr/lib/anaconda/gui.py", line 1518, in setup_window
    self.setScreen()
  File "/usr/lib/anaconda/gui.py", line 1528, in run
    self.setup_window(runres)
  File "/usr/lib/anaconda/gui.py", line 1275, in run
    self.icw.run (self.runres)
  File "/usr/bin/anaconda", line 1013, in <module>
    anaconda.intf.run(anaconda)
KeyError: 's'


Full report attached. A couple other comments though:

- There seems to be a pykickstart backtrace in the report as well
- Is the report supposed to have a copy of the kickstart file used? If not, I think that's a good idea. (Maybe the 2nd backtrace was from trying to dump the ks).
- There are deprecation warnings in the log about old kickstart options, but the line number reporting seems busted, since they both warn about line '0'
Comment 1 Chris Lumens 2009-02-18 11:45:37 EST

*** This bug has been marked as a duplicate of bug 485622 ***

Note You need to log in before you can comment on or make changes to this bug.