Bug 486160 - package dependency errors for proxy install
package dependency errors for proxy install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Tomas Lestach
Jan Pazdziora
:
Depends On:
Blocks: 456999
  Show dependency treegraph
 
Reported: 2009-02-18 12:33 EST by Shannon Hughes
Modified: 2009-09-10 10:37 EDT (History)
5 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 10:37:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shannon Hughes 2009-02-18 12:33:41 EST
Description of problem:

spacewalk-proxy-broker-0.5.6-1.el5sat.noarch from redhat-rhn-proxy-5.3-server-i386-5 has depsolving problems
  --> Missing Dependency: spacewalk-certs-tools is needed by package spacewalk-proxy-broker-0.5.6-1.el5sat.noarch (redhat-rhn-proxy-5.3-server-i386-5)
spacewalk-proxy-management-0.5.6-1.el5sat.noarch from redhat-rhn-proxy-5.3-server-i386-5 has depsolving problems
  --> Missing Dependency: spacewalk-backend is needed by package spacewalk-proxy-management-0.5.6-1.el5sat.noarch (redhat-rhn-proxy-5.3-server-i386-5)
spacewalk-proxy-broker-0.5.6-1.el5sat.noarch from redhat-rhn-proxy-5.3-server-i386-5 has depsolving problems
  --> Missing Dependency: spacewalk-ssl-cert-check is needed by package spacewalk-proxy-broker-0.5.6-1.el5sat.noarch (redhat-rhn-proxy-5.3-server-i386-5)
spacewalk-proxy-package-manager-0.5.6-1.el5sat.noarch from redhat-rhn-proxy-5.3-server-i386-5 has depsolving problems
  --> Missing Dependency: spacewalk-backend is needed by package spacewalk-proxy-package-manager-0.5.6-1.el5sat.noarch (redhat-rhn-proxy-5.3-server-i386-5)

Version-Release number of selected component (if applicable):


How reproducible:

synced packages from webqa
Comment 1 Clifford Perry 2009-02-19 10:47:13 EST
Asking Shannon to cleanup the bug. Not sure what needs fixing, packages pushed, channels for packages, spec require/dep statements! ?!?!? :)
Comment 2 Dennis Gilmore 2009-02-19 12:09:40 EST
recomposed and pushed with packages in comps
Comment 3 Shannon Hughes 2009-03-05 07:40:21 EST
test plan:

after scheduling a proxy install from the web ui successfully, run rhn_check on the box and confirm you do not have package dependencies.
Comment 4 wes hayutin 2009-03-23 11:16:42 EDT
is action will be executed after 03/23/09 11:07:10 AM EDT.

This action's status is: Failed.
The client picked up this action on 03/23/09 11:07:16 AM EDT.
The client completed this action on 03/23/09 11:11:35 AM EDT.
Client execution returned "Failed: packages requested raised dependency problems" (code 18)
Packages Scheduled:

    * rhns-proxy-monitoring-5.2.0-2.el4
    * rhns-proxy-management-5.2.0-15.el4

Dependency errors encountered:

    * MessageQueue-3.26.0-6.el4 requires NPusers
    * NOCpulsePlugins-2.208.0-30.el4 requires NPusers
    * NPalert-1.125.17-21.el4 requires NPusers
    * perl-NOCpulse-Debug-1.23.4-7.el4 requires np-config
    * perl-NOCpulse-Debug-1.23.4-7.el4 requires NPusers
    * perl-NOCpulse-Gritch-1.16.1-6.el4 requires np-config
    * perl-NOCpulse-Probe-1.183.1-22.el4 requires NPusers
    * perl-NOCpulse-Scheduler-1.58.4-8.el4 requires NPusers
    * perl-NOCpulse-Utils-1.14.2-9.el4 requires NPusers
    * ProgAGoGo-1.11.0-5.el4 requires NPusers
    * rhnmd-5.1.6-1.el4sat conflicts with nocpulse-common
    * rhns-proxy-broker-5.2.0-15.el4 requires rhn-ssl-cert-check
    * rhns-proxy-broker-5.2.0-15.el4 requires >= rhns-certs-tools-3.6.0
    * rhns-proxy-monitoring-5.2.0-2.el4 requires np-config
    * rhns-proxy-monitoring-5.2.0-2.el4 conflicts with rhnmd
    * rhns-proxy-monitoring-5.2.0-2.el4 requires NPusers
    * SatConfig-bootstrap-1.11.0-7.el4 requires np-config
    * SatConfig-bootstrap-1.11.0-7.el4 requires NPusers
    * SatConfig-general-1.215.38-10.el4 requires NPusers
    * SatConfig-general-1.215.38-10.el4 requires np-config

View all 31 dependency errors
Comment 5 wes hayutin 2009-03-23 11:17:19 EDT
D: Conflicts: [('rhnmd', 'nocpulse-common'), ('rhns-proxy-monitoring', 'rhnmd')]
D: Candidates for the selected list: []
D: Sending back response (18, 'Failed: packages requested raised dependency problems', {'failed_deps': ((('MessageQueue', '3.26.0', '6.el4'), ('NPusers', ''), 0, '', 0), (('NOCpulsePlugins', '2.208.0', '30.el4'), ('NPusers', ''), 0, '', 0), (('NPalert', '1.125.17', '21.el4'), ('NPusers', ''), 0, '', 0), (('ProgAGoGo', '1.11.0', '5.el4'), ('NPusers', ''), 0, '', 0), (('SatConfig-bootstrap', '1.11.0', '7.el4'), ('NPusers', ''), 0, '', 0), (('SatConfig-bootstrap', '1.11.0', '7.el4'), ('np-config', ''), 0, '', 0), (('SatConfig-general', '1.215.38', '10.el4'), ('NPusers', ''), 0, '', 0), (('SatConfig-general', '1.215.38', '10.el4'), ('np-config', ''), 0, '', 0), (('SatConfig-generator', '2.29.5', '9.el4'), ('NPusers', ''), 0, '', 0), (('SatConfig-generator', '2.29.5', '9.el4'), ('np-config', ''), 0, '', 0), (('SatConfig-installer', '3.24.0', '7.el4'), ('NPusers', ''), 0, '', 0), (('SatConfig-installer', '3.24.0', '7.el4'), ('np-config', ''), 0, '', 0), (('SputLite-client', '0.48.0', '5.el4'), ('NPusers', ''), 0, '', 0), (('SputLite-server', '0.48.0', '5.el4'), ('NPusers', ''), 0, '', 0), (('perl-NOCpulse-Debug', '1.23.4', '7.el4'), ('NPusers', ''), 0, '', 0), (('perl-NOCpulse-Debug', '1.23.4', '7.el4'), ('np-config', ''), 0, '', 0), (('perl-NOCpulse-Gritch', '1.16.1', '6.el4'), ('np-config', ''), 0, '', 0), (('perl-NOCpulse-Probe', '1.183.1', '22.el4'), ('NPusers', ''), 0, '', 0), (('perl-NOCpulse-Scheduler', '1.58.4', '8.el4'), ('NPusers', ''), 0, '', 0), (('perl-NOCpulse-Utils', '1.14.2', '9.el4'), ('NPusers', ''), 0, '', 0), (('rhnmd', '5.1.6', '1.el4sat'), ('nocpulse-common', ''), 0, '', 1), (('rhns-proxy-broker', '5.2.0', '15.el4'), ('rhn-ssl-cert-check', ''), 0, '', 0), (('rhns-proxy-broker', '5.2.0', '15.el4'), ('rhns-certs-tools', '3.6.0'), 12, '', 0), (('rhns-proxy-monitoring', '5.2.0', '2.el4'), ('NPusers', ''), 0, '', 0), (('rhns-proxy-monitoring', '5.2.0', '2.el4'), ('np-config', ''), 0, '', 0), (('rhns-proxy-monitoring', '5.2.0', '2.el4'), ('rhnmd', ''), 0, '', 1), (('scdb', '1.15.3', '13.el4'), ('NPusers', ''), 0, '', 0), (('ssl_bridge', '1.9.0', '6.el4'), ('NPusers', ''), 0, '', 0), (('status_log_acceptor', '0.12.5', '8.el4'), ('NPusers', ''), 0, '', 0), (('status_log_acceptor', '0.12.5', '8.el4'), ('np-config', ''), 0, '', 0), (('tsdb', '1.27.13', '20.el4'), ('NPusers', ''), 0, '', 0)), 'version': '0', 'name': 'packages.update.failed_deps'})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
D: local action status:  (0, 'rpm database not modified since last update (or package list recently updated)', {})
Comment 7 Tomas Lestach 2009-06-03 04:52:16 EDT
Installation of RHN Proxy 5.3 over WEBUI (+rhn_check) doesn't show any dependency errors.

Missing packages from #Description are present:
# rpm -q spacewalk-certs-tools
spacewalk-certs-tools-0.5.5-5.el5sat
# rpm -q spacewalk-backend
spacewalk-backend-0.5.28-14.el5sat
# rpm -q spacewalk-ssl-cert-check
spacewalk-ssl-cert-check-1.7-1.el5sat


Tested with sat version: Satellite-5.3.0-RHEL5-re20090520.0 and redhat-rhn-proxy-5.3-server-i386-5 channel synced from webqa.
Comment 9 Jan Pazdziora 2009-06-30 09:52:55 EDT
With Satellite-5.3.0-RHEL5-re20090625.0 on i386, I was able to schedule RHN Proxy 5.3 installation via Satellite's WebUI. When picked by rhn_check, the packages were installed from the Satellite, and additional actions run OK as well. On the http://fqdn-of-the-proxy/ there is RHN Proxy's title page now.

Packages installed on the RHN Proxy machine after the installations are:

# rpm -qa | egrep 'rhn|spacewalk' | sort
rhncfg-5.9.5-3.el5sat
rhncfg-actions-5.9.5-3.el5sat
rhncfg-client-5.9.5-3.el5sat
rhn-check-0.4.19-17.el5
rhn-client-tools-0.4.19-17.el5
rhnlib-2.2.6-2.el5
rhn-proxy-branding-5.3.0.24-1.el5sat
rhnsd-4.6.1-1.el5
rhn-setup-0.4.19-17.el5
spacewalk-backend-0.5.28-24.el5sat
spacewalk-base-minimal-0.5.23-20.el5sat
spacewalk-certs-tools-0.5.5-6.el5sat
spacewalk-monitoring-selinux-0.5.7-9.el5sat
spacewalk-proxy-broker-0.5.7-7.el5sat
spacewalk-proxy-common-0.5.7-7.el5sat
spacewalk-proxy-docs-0.4.1-2.el5sat
spacewalk-proxy-management-0.5.7-7.el5sat
spacewalk-proxy-monitoring-0.4.4-3.el5sat
spacewalk-proxy-package-manager-0.5.7-7.el5sat
spacewalk-proxy-redirect-0.5.7-7.el5sat
spacewalk-proxy-selinux-0.5.2-6.el5sat
spacewalk-ssl-cert-check-1.7-1.el5sat
yum-rhn-plugin-0.5.3-30.el5
#

Marking as VERIFIED.
Comment 10 Brandon Perkins 2009-09-10 10:37:47 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1433.html

Note You need to log in before you can comment on or make changes to this bug.