Bug 486184 - Screen max size too small for my displays
Screen max size too small for my displays
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 14:28 EST by Mads Kiilerich
Modified: 2009-03-06 09:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-06 09:04:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (78.02 KB, text/plain)
2009-02-18 14:28 EST, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2009-02-18 14:28:30 EST
Created attachment 332439 [details]
Xorg.0.log

Description of problem:

When i try to use both my displays side by side it complains because the screen max isn't big enough, as shown by xrandr output. That also causes the gnome display setting tool to fail.

xorg-x11-drv-ati-6.10.0-3.fc11.i586 - no xorg.conf and no KMS (because it currently is disabled in rawhide kernels?)
01:00.0 VGA compatible controller: ATI Technologies Inc RV516 [Radeon X1300/X1550 Series]
01:00.1 Display controller: ATI Technologies Inc RV516 [Radeon X1300 Pro] (Secondary)

xrandr -q 
Screen 0: minimum 320 x 200, current 2560 x 1024, maximum 2560 x 1600
DVI-1 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 473mm x 296mm
   1680x1050      59.9 +
   1280x1024      75.0     60.0* 
   1152x864       75.0  
   1024x768       75.0     60.0  
   800x600        75.0     60.3  
   640x480        75.0     59.9  
   720x400        70.1  
DVI-0 connected 1280x1024+1280+0 (normal left inverted right x axis y axis) 338mm x 270mm
   1280x1024      60.0*+   75.0     60.0* 
   1152x864       75.0  
   1024x768       75.0     60.0  
   800x600        75.0     60.3  
   640x480        75.0     59.9  
   720x400        70.1  

When I try to use the max resolution it fails because 1680+1280 > 2560.

FWIW it worked fine with F10
Comment 1 Mads Kiilerich 2009-03-06 09:04:30 EST
Whereever the problem was: it works now, at xorg-x11-drv-ati-6.11.0-3.fc11.i586 o'clock.

Screen 0: minimum 320 x 200, current 2960 x 1050, maximum 8192 x 8192

Note You need to log in before you can comment on or make changes to this bug.