This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 486188 - ISE on selecting the Organization tab for a protected channel in a trusted org.
ISE on selecting the Organization tab for a protected channel in a trusted org.
Status: CLOSED DUPLICATE of bug 484768
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
530
All Linux
high Severity medium
: ---
: ---
Assigned To: Shannon Hughes
Preethi Thomas
:
Depends On:
Blocks: 456998
  Show dependency treegraph
 
Reported: 2009-02-18 14:41 EST by Preethi Thomas
Modified: 2009-07-31 16:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-20 07:52:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2009-02-18 14:41:29 EST
Description of problem:

ISE on selecting the Organization tab for a shared channel
Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090213.1-i386-embedded-oracle.iso

How reproducible:

always
Steps to Reproduce:
1. create org1
2. create a protected channel
2. have a trust between the main org and org1
3. navigate to channels->manage software channels
4 click on the channel name (channel1)
5. try to select the organization tab
  
Actual results:
ISE

Expected results:
orgnization tab

Additional info:
The following exception occurred while executing this request:
GET /rhn/multiorg/channels/OrgList.do

Date:2/18/09 2:37:24 PM EST
Headers:
  host: rlx-0-10.rhndev.redhat.com
  user-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.2) Gecko/2008091816 Red Hat/3.0.2-3.el5 Firefox/3.0.2
  accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
  accept-language: en-us,ar;q=0.8,ja;q=0.5,ml;q=0.3
  accept-encoding: gzip,deflate
  accept-charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
  Keep-Alive: 300
  connection: keep-alive
  referer: https://rlx-0-10.rhndev.redhat.com/rhn/channels/manage/Edit.do?cid=141
  cookie: JSESSIONID=9CE28DC17A1AB3D4EED5EC7CAC913657; rh_omni_tc=70160000000H4AjAAK; s_vi=[CS]v1|499AD56A000016E6-A3A095600005320[CE]; s_cc=true; s_sq=%5B%5BB%5D%5D; rh_sso=0|JNNviZqRQfWm2eJKTY4yPX2lxG1RWGVJTMH; rh_user=preethit|Preethi|member; rh_shared_auth=f6b2b98de81805650fc51fbb5c2779b96dc3bdd2a4fafe73794bd21c364d85e7ed207c9c60ecf65bbce3d5300bcf2e4157afa45797f3d6430539117d62875df9; pxt-session-cookie=42xbc895ad399bd207ef4f4165735e107a1

Request:
Local Name = rlx-0-10.rhndev.redhat.com
Server Name = rlx-0-10.rhndev.redhat.com
Requested Session Id came from Cookie
Requested Session Valid = true
Session = org.apache.catalina.session.StandardSessionFacade@77897789[session=StandardSession[9CE28DC17A1AB3D4EED5EC7CAC913657]]
Protocol = https
Request Locale = en_US
Request Character Encoding = UTF-8
Attribute Names = rhnActiveLang, javax.servlet.jsp.jstl.fmt.timeZone.request, javax.servlet.request.key_size, __sitemesh__filterapplied, javax.servlet.request.ssl_session, javax.servlet.request.cipher_suite, org.apache.struts.action.MESSAGE, session, org.apache.struts.action.mapping.instance, requestedUri, org.apache.struts.action.MODULE,


User Information:
User admin (id 1, org_id 1)

Exception:
javax.servlet.ServletException
        at org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:535)
        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:433)
        at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:237)
        at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:82)
        at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
        at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:73)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)
        at com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:67)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:108)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:55)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:210)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:172)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151)
        at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:200)
        at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283)
        at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:773)
        at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)
        at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:895)
        at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:685)
        at java.lang.Thread.run(Thread.java:735)
Caused by: java.lang.NullPointerException
        at com.redhat.rhn.common.translation.Translations.convert(Translations.java:39)
        at com.redhat.rhn.common.translation.Translator.convert(Translator.java:45)
        at com.redhat.rhn.common.util.MethodUtil.callMethod(MethodUtil.java:166)
        at com.redhat.rhn.common.db.datasource.CachedStatement.addToObject(CachedStatement.java:748)
        at com.redhat.rhn.common.db.datasource.CachedStatement.processResultSet(CachedStatement.java:598)
        at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:461)
        at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:431)
        at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:335)
        at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:340)
        at com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:280)
        at com.redhat.rhn.common.db.datasource.SelectMode.execute(SelectMode.java:105)
        at com.redhat.rhn.common.db.datasource.DataList.getDataList(DataList.java:71)
        at com.redhat.rhn.manager.org.OrgManager.orgChannelTrusts(OrgManager.java:170)
        at com.redhat.rhn.frontend.action.multiorg.OrgChannelListAction$OrgSet.getResult(OrgChannelListAction.java:147)
        at com.redhat.rhn.frontend.taglibs.list.collection.WebList.setupDataSet(WebList.java:57)
        at com.redhat.rhn.frontend.taglibs.list.collection.WebList.<init>(WebList.java:45)
        at com.redhat.rhn.frontend.taglibs.list.collection.SelectableWebList.<init>(SelectableWebList.java:44)
        at com.redhat.rhn.frontend.action.multiorg.OrgChannelListAction.setupAction(OrgChannelListAction.java:57)
        at com.redhat.rhn.frontend.action.DispatchedAction.execute(DispatchedAction.java:55)
        at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
        ... 40 more
Comment 1 Shannon Hughes 2009-02-20 07:52:36 EST

*** This bug has been marked as a duplicate of bug 484768 ***
Comment 2 Brad Buckingham 2009-07-31 11:31:39 EDT
The scenario described by this BZ is different from bug 484768; however, the resulting ISE is the same.  As a result, marking as CloseValid; however, also confirmed that this scenario described no longer generates ISE in 7/24 stage iso.

Note You need to log in before you can comment on or make changes to this bug.