Bug 486199 - intermittent loader failure in slang bindings
intermittent loader failure in slang bindings
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dosbox (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 15:34 EST by Derek Atkins
Modified: 2009-08-06 09:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-05 12:15:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Atkins 2009-02-18 15:34:15 EST
Description of problem:

I'm trying to run dosemu (see bug #456190) but I'm seeing intermittent loader failures from SLANG:

[warlord@pgpdev bootguard]$ dosemu -t "C:\\build.bat"
/usr/bin/dosemu: relocation error: /usr/lib/dosemu/libplugin_term.so: symbol SLtt_get_terminfo, version SLANG2 not defined in file libslang.so.2 with link time reference
[warlord@pgpdev bootguard]$ dosemu -t "C:\\build.bat"
/usr/bin/dosemu: relocation error: /usr/lib/dosemu/libplugin_term.so: symbol SLtt_get_terminfo, version SLANG2 not defined in file libslang.so.2 with link time reference
[warlord@pgpdev bootguard]$ dosemu -t "C:\\build.bat"
/usr/bin/dosemu: relocation error: /usr/lib/dosemu/libplugin_term.so: symbol SLtt_get_terminfo, version SLANG2 not defined in file libslang.so.2 with link time reference
[warlord@pgpdev bootguard]$ dosemu -t "C:\\build.bat"
/usr/bin/dosemu: relocation error: /usr/lib/dosemu/libplugin_term.so: symbol SLtt_get_terminfo, version SLANG2 not defined in file libslang.so.2 with link time reference
[warlord@pgpdev bootguard]$ dosemu -t "C:\\build.bat"
Note that DOS needs 25 lines. You might want to enlarge your
window before continuing.

Now type ENTER to start DOSEMU or <Ctrl>C to cancel


Version-Release number of selected component (if applicable):

dosemu-1.4.0-1.1868svn.i386
slang-2.1.4-1.fc10.i386

How reproducible:

It seems to be intermittent.  Sometimes it works.  Sometimes it fails.  I can't seem to figure out why or what seems to differ.  I can run the same command over and over and it will fail then succeed without making any other changes to my system.  But it always fails in the same way.

Steps to Reproduce:
1. install dosemu
2. run it.
3.
  
(It's POSSIBLE) that it's part of my dosemu environment that's causing the issue, but this issue is new to F10 and I wasn't having this issue before so I think something in F10 changed and started to get this issue to occur.

Actual results:

See above.

Expected results:

dosemu should run every time.

Additional info:
Comment 1 Miroslav Lichvar 2009-08-04 11:01:13 EDT
Symbol SLtt_get_terminfo with version SLANG2 is defined in libslang.so.2, so I think this is a bug in dosbox related to dynamic loading.
Comment 2 Derek Atkins 2009-08-05 07:44:36 EDT
So if this is a bug in dosbox, why not reassign it there instead of closing it outright?  Geeze.

Re-opened and re-assigned to dosbox.
Comment 3 Andreas Bierfert 2009-08-05 12:15:46 EDT
This has nothing to do with dosbox. It is regarding dosemu. Dosemu is not part of fedora so please go ahead and file a bug wherever you get dosemu from.
Comment 4 Derek Atkins 2009-08-06 09:06:30 EDT
I'm not convinced it's a bug in dosemu.  It was working find in Fedora 7, and when I upgraded to Fedora 10 I rebuilt the SAME VERSION of dosemu and saw this problem.  So the only changes were F7->F10 deps (and compiler toolchain).  So I do think it's a problem somewhere in F10, not in dosemu.

But whatever, if you're not willing to help then fine.

Note You need to log in before you can comment on or make changes to this bug.