Bug 486203 - Tomboy doesn't start
Tomboy doesn't start
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: tomboy (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 15:54 EST by Matthias Clasen
Modified: 2009-02-20 12:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-20 12:13:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2009-02-18 15:54:51 EST
This is with
tomboy-0.13.4-2.fc11.x86_64
mono-addins-0.4-4.20091002svn126354.fc11.x86_64
mono-core-2.4-6.pre2.20091002svn126522.fc11.x86_64

[mclasen@planemask ~]$ tomboy
[DEBUG]: NoteManager created with note path "/home/mclasen/.tomboy".
[INFO]: Initializing Mono.Addins

Unhandled Exception: System.InvalidOperationException: Could not read add-in description
  at Mono.Addins.Addin.get_Description () [0x00000] 
  at Mono.Addins.AddinSessionService.CheckHostAssembly (System.Reflection.Assembly asm) [0x00000] 
  at Mono.Addins.AddinSessionService.ActivateRoots () [0x00000] 
  at Mono.Addins.AddinSessionService.Initialize () [0x00000] 
  at Mono.Addins.AddinManager.Initialize (System.String configDir) [0x00000] 
  at Tomboy.AddinManager.InitializeMonoAddins () [0x00000] 
  at Tomboy.AddinManager..ctor (System.String tomboy_conf_dir) [0x00000] 
  at Tomboy.NoteManager.CreateAddinManager () [0x00000] 
  at Tomboy.NoteManager..ctor (System.String directory, System.String backup_directory) [0x00000] 
  at Tomboy.NoteManager..ctor (System.String directory) [0x00000] 
  at Tomboy.Tomboy.Main (System.String[] args) [0x00000]
Comment 1 Matthias Clasen 2009-02-20 12:13:05 EST
turns out that removing the addins directory in .tomboy that I copied from i386 to x86_64 fixed it. So much for arch independence...

Note You need to log in before you can comment on or make changes to this bug.