Bug 486222 - [LTC 6.0 FEAT] Linux to add Call Home data - Kernel Interface [201801]
[LTC 6.0 FEAT] Linux to add Call Home data - Kernel Interface [201801]
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
s390x All
low Severity high
: rc
: 6.0
Assigned To: Red Hat Kernel Manager
Martin Jenner
: FutureFeature
Depends On:
Blocks: 356741 463282
  Show dependency treegraph
 
Reported: 2009-02-18 17:10 EST by IBM Bug Proxy
Modified: 2010-06-08 09:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-22 17:20:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 51753 None None None Never

  None (edit)
Description IBM Bug Proxy 2009-02-18 17:10:51 EST
=Comment: #0=================================================
Hans-Georg Markgraf <mgrf@de.ibm.com> - 
1. Feature Overview:
Feature Id:	[201801]
a. Name of Feature:	Linux to add Call Home data  - kernel interface

b. Feature Description
This item implements a new sysfs interface which complements the existing one (previous sclp_cpi
kernel module), that allows the association of a set of descriptive data called "Control Program
Identification" (CPI) with an operating system instance (currently LPAR only). This information is
not persistent and has to be set once per IPL. CPI data will be visible at the HMC/SE. CPI
information is also referred to as "Call Home data" in some contexts. CPI information could
previously be set by loading the sclp_cpi kernel module. The new interface was included in Linux
kernel 2.6.25. These sysfs-attributes can be used to specify the CPI information locally:
/sys/firmware/cpi/system_name String: arbitrary, user-specified system name (e.g. LPAR12)
/sys/firmware/cpi/sysplex_name String: arbitrary, user-specified sysplex name (e.g. SYSPLEX1)
/sys/firmware/cpi/system_type String: operating system type identifier - must be "LINUX "
/sys/firmware/cpi/system_level Hex: operating system version information, should be
0x0000000000aabbcc, where aa=kernel version, bb=kernel patch level, cc=kernel sublevel. Example:
Linux kernel 2.6.26 -> 0x000000000002061a Once all attributes are filled, write an arbitrary string
to this attribute to finalize the data (i.e. to send it to the SE): /sys/firmware/cpi/system_set

2. Feature Details:
Sponsor:	zSeries
Architectures:
s390x

Arch Specificity: Purely Arch Specific Code
Affects Core Kernel: Yes
Delivery Mechanism: Direct from community
Category:	zSeries
Request Type:	Driver - Feature from IBM
d. Upstream Acceptance:	Accepted 
Sponsor Priority	1
f. Severity: High
IBM Confidential:	no
Code Contribution:	IBM code
g. Component Version Target:	k 2.6.25

3. Business Case
This feature provides a better overview for the customer of their systems from the HMC, and a better
service for the customer, since helps to know the correct kernel version in service reports. That
is: RAS Improvement by decreasing mean time to resolve problems in case of System Failure.

4. Primary contact at Red Hat: 
John Jarvis
jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Hans-Georg Markgraf, mgrf@de.ibm.com, Boeblingen 49-7031-16-3978

Technical contact(s):
Gonzalo Muelas Serrano, gmuelas@de.ibm.com 

IBM Manager:
Thomas Schwarz, t.schwarz@de.ibm.com
Comment 1 IBM Bug Proxy 2009-02-19 08:40:38 EST
This feature has a required installer - tools related feature request

48137 - RHBZ 463282  [LTC 6.0 FEAT] 201167:Linux to add Call Home data - Installer and Tools enhancements
Comment 2 Bill Nottingham 2009-02-26 14:15:31 EST
If this is in 2.6.25, that shouldn't be an issue. RHEL 6 will include a much later kernel.

The feature requested has already been accepted into the upstream code base
planned for the next major release of Red Hat Enterprise Linux.

When the next milestone release of Red Hat Enterprise Linux 6 is available,
please verify that the feature requested is present and functioning as
desired.
Comment 3 Hans-Joachim Picht 2009-09-22 17:20:03 EDT
Code is included in the rhel6 kernel via upstream. Marked as
CLOSED/CURRENTRELEASE by Hans-Joachim Picht <hpicht@redhat.com>
Comment 4 IBM Bug Proxy 2010-06-08 09:00:40 EDT
------- Comment From mgrf@de.ibm.com 2010-06-08 08:57 EDT-------
This feature is verified
- with one bug report opened - severity low
LTC 63950   -  RIT990833 - Control Program identification(Call home data)

Also that bug report is not yet resolved - I set this feature to verified. Thx

Note You need to log in before you can comment on or make changes to this bug.