Bug 486224 - Localization issues in Openoffice.org Calc causes problems for functions
Localization issues in Openoffice.org Calc causes problems for functions
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-18 17:21 EST by J.H.
Modified: 2009-02-20 05:03 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-20 05:03:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 92056 None None None Never
Launchpad 306602 None None None Never

  None (edit)
Description J.H. 2009-02-18 17:21:26 EST
Description of problem:

It seems the localization of Openoffice.org Calc (specifically) slightly changed between version 2 and version 3.  In previous versions of OO.o Calc the function parameter delimiter was ','.  However in OO.org 3 they changed the function delimiter to be based on the localization, which under Fedora (and in checking Ubuntu, and OS X) this changes from ',' to ';'.

https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/306602 also details the same bug.  In talking with some people from OO.o OO.o now reads the localization information from the OS as opposed to hard coding the ',' into the program.  The delimiter seems to get opened and saved correctly, but when typed directly it just causes errors

Version-Release number of selected component (if applicable):

OO.o Calc 3+

How reproducible:

Always

Steps to Reproduce:
1. Open OO.o Calc
2. enter "hi" into cell A1
3. enter =IF(A1="hi",TRUE,FALSE) into cell A2
4. enter =IF(A1="hi";TRUE;FALSE) into cell A3

Actual results:

Cell A2 will error, cell A3 will return 

Expected results:

Cell A2 will return given an American/English localization, cell A3 will error given an American/English localization
Additional info:
Comment 1 Caolan McNamara 2009-02-18 18:27:46 EST
"It seems the localization of Openoffice.org Calc (specifically) slightly
changed between version 2 and version 3."

Are you sure about this. ";" has been the separator in all locales since forever as far as I know. (Though it is possible that the ooo-build/go-ooo.org family has some tweakery in there to allow , to be more excel-alike, but we wouldn't have carried any such change in an 2.x.y release)

i.e. your A2 example errors in F-9 that has 2.4.2 as well as in F-10+ that have 3.0.1+ and that's the behaviour that I expect. Did you compare perhaps a non-fedora OOo2 to fedora OOo3
Comment 2 David Tardon 2009-02-19 02:47:36 EST
It works just the same (i.e. A2 -> #NAME?, A3 -> 1) in 1.1.5 in RHEL 4.7.
Comment 3 Caolan McNamara 2009-02-19 03:35:15 EST
I suspect that this issue is not actually a Fedora issue, or a vanilla OOo issue, where ";" is and has been the separator always. But a more recent go.ooo.org extension (maybe http://qa.openoffice.org/issues/show_bug.cgi?id=92056) to allow "," for excel-UI compatibility that may have gone slightly awry. I see patches in ooo-build to implement that suggested feature.
Comment 4 Caolan McNamara 2009-02-20 05:03:07 EST
Pretty sure that this is just information leakage over from the ooo-build experimental feature to allow "," as a separator in calc formulas. Something that we haven't ever done in Fedora (or in vanilla) so its not a bug here.

Note You need to log in before you can comment on or make changes to this bug.