Bug 486301 - Traceback on start-up
Traceback on start-up
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gwibber (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Ian Weller
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-19 04:51 EST by Tim Waugh
Modified: 2009-07-02 18:21 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.2.0-1.345bzr.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-02 18:21:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gwibber-traceback.patch (968 bytes, patch)
2009-02-19 04:51 EST, Tim Waugh
no flags Details | Diff

  None (edit)
Description Tim Waugh 2009-02-19 04:51:12 EST
Description of problem:
I see this when starting gwibber:

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/gwibber/gwui.py", line 81, in on_click_link
    if not self.link_handler(uri, self) and self.load_externally:
TypeError: link_handler() takes exactly 2 arguments (3 given)
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/gwibber/gwui.py", line 81, in on_click_link
    if not self.link_handler(uri, self) and self.load_externally:
TypeError: link_handler() takes exactly 2 arguments (3 given)

Version-Release number of selected component (if applicable):
gwibber-0.7.3-4.223bzr.fc10
WebKit-gtk-1.1.0-0.16.svn40351.fc10.x86_64

Additional info:
I think the reason that code is getting executed in the first place is because of a WebKit change; however I think the attached patch is needed.
Comment 1 Tim Waugh 2009-02-19 04:51:55 EST
Created attachment 332517 [details]
gwibber-traceback.patch
Comment 2 Ian Weller 2009-02-19 16:34:33 EST
Am I correct in thinking that you said this was caused by the webkit update on bodhi with bad karma?

If so please close NOTABUG or reassign to WebKit :)
Comment 3 Tim Waugh 2009-02-20 08:51:08 EST
Well, that's when I first saw the traceback.  However, looking at the code, 'link_handler' does indeed take two arguments so 'self.link_handler(uri, self)' (passing three) seems wrong.
Comment 4 Ian Weller 2009-06-26 13:47:04 EDT
Hey Tim, is this bug still a problem? I haven't seen it in my use.
Comment 5 Tim Waugh 2009-06-28 15:56:31 EDT
Not seeing it with:

gwibber-1.0.1-1.286bzr.fc10.noarch
WebKit-gtk-1.0.0-0.15.svn37790.fc10.x86_64

but the original report was with a newer WebKit-gtk package.  Will re-test with the updates-testing WebKit-gtk package this week and update this report.
Comment 6 Tim Waugh 2009-07-02 04:10:46 EDT
Works fine with:

gwibber-1.2.0-1.345bzr.fc10.noarch
WebKit-gtk-1.1.0-0.16.svn40351.fc10.x86_64

although I had to re-enter my password in order to avoid '401 unauthorized' errors.  Not sure why -- I just copied it from what was already in my keyring.
Comment 7 Ian Weller 2009-07-02 18:21:47 EDT
There was some revision in between that that had wacky things going with the GNOME keyring. Sorry for the inconvenience on that.

I'm gonna go ahead and say this was fixed in version 1.2.0-1.345bzr.fc10

Note You need to log in before you can comment on or make changes to this bug.