Bug 486345 - udev (again) not setting permissions properly for /dev/dvdrw
udev (again) not setting permissions properly for /dev/dvdrw
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: ConsoleKit (Show other bugs)
11
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-19 08:29 EST by Jonathan Kamens
Modified: 2015-01-14 18:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 07:19:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2009-02-19 08:29:05 EST
With this DVD-RW drive:

ata2.00: ATAPI: SONY    DVD RW DW-D26A, JYS3, max UDMA/66
ata2.00: configured for UDMA/66
scsi 1:0:0:0: CD-ROM            SONY     DVD RW DW-D26A   JYS3 PQ: 0 ANSI: 5
sr0: scsi3-mmc drive: 62x/62x writer cd/rw xa/form2 cdda tray
Uniform CD-ROM driver Revision: 3.20
sr 1:0:0:0: Attached scsi CD-ROM sr0
sr 1:0:0:0: Attached scsi generic sg2 type 5

and current rawhide (kernel-PAE-2.6.29-0.124.rc5.fc11.i686, udev-137-4.fc11.i386), udev is once again not making /dev/dvdrw writable when I put a blank DVD in the drive.

It seems like this problem comes and goes and comes and goes repeatedly.  Sure would be nice if it would just GO and stay gone.

Don't think F11 can ship with this broken.
Comment 1 Harald Hoyer 2009-02-19 08:41:41 EST
please provide the output of:

# getfacl /dev/sr0
Comment 2 Jonathan Kamens 2009-02-19 08:56:39 EST
With blank DVD in drive:

jik2:~!1067$ sudo getfacl /dev/sr0
getfacl: Removing leading '/' from absolute path names
# file: dev/sr0
# owner: root
# group: cdrom
user::rw-
group::rw-
mask::rw-
other::---

jik2:~!1068$ ls -l /dev/sr0
brw-rw----+ 1 root cdrom 11, 0 2009-02-17 10:29 /dev/sr0
jik2:~!1069$ 

Looks like the perms are find, but the owner isn't (should be jik, not root, since I'm logged in on the console).
Comment 3 Harald Hoyer 2009-02-19 09:10:00 EST
it's all done with ACLs now.. no more chown, but you are missing from the ACLs ..
Comment 4 Jonathan Kamens 2009-02-19 09:14:33 EST
ACLs aren't enabled on the filesystem.

What's the upgrade path?
Comment 5 Jonathan Kamens 2009-02-19 09:24:53 EST
Hmm, just occurred to me that whether ACLs are enabled on / doesn't matter, since /dev is its own filesystem.

Nonetheless, just to rule that out, I tried enabling acls on / and rebooting, and it's still not working.

Suggestions?
Comment 6 Harald Hoyer 2009-02-19 10:43:48 EST
I reassigned the bug already to consolekit which is supposed to set the ACLs for the console user.
Comment 7 Fedora Admin XMLRPC Client 2009-04-08 13:08:50 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Bug Zapper 2009-06-09 07:30:38 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bug Zapper 2010-04-27 09:01:19 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2010-06-28 07:19:24 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.