This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 486396 - Kickstart install cannot determine local yum repository
Kickstart install cannot determine local yum repository
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-19 11:08 EST by Harry Dolan
Modified: 2009-06-08 14:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-08 14:12:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot of error message (40.07 KB, image/jpeg)
2009-02-19 11:11 EST, Harry Dolan
no flags Details
Kickstart file (1.71 KB, text/plain)
2009-02-19 11:30 EST, Harry Dolan
no flags Details
/tmp/anaconda.log file (10.05 KB, text/plain)
2009-02-25 12:38 EST, Harry Dolan
no flags Details

  None (edit)
Description Harry Dolan 2009-02-19 11:08:47 EST
Description of problem: Installing from hard disk with a kickstart file and no internet connection, anaconda complains of missing repodata.  It makes no such complaint when done interactively (i.e., no kickstart file).  However, when the boot line specifies a repo (as the same place as the image files) it works OK.  This is not necessary when done interactively


Version-Release number of selected component (if applicable): 10.5-0-12


How reproducible:


Steps to Reproduce:
1.Put Fedora images on hard disk.  Mine looks like this:
linbox# ls /mystuff/distros/fedora/11
anaconda-ks.cfg               GETIT.sh*  ks-linbox-f11.cfg       Umount-iso.sh*
Everything/                   images/    ks-linbox-f11.cfg.rev0
Fedora-11-Alpha-i386-DVD.iso  isolinux/  Mount-iso.sh*

2.Boot using kickstart file.  I use this:

title Install Fedora 11 Alpha
	root (hd1,0)
	kernel /distros/fedora/11/isolinux/vmlinuz ks=hd:sdb1:distros/fedora/11/ks-linbox-f11.cfg
	initrd /distros/fedora/11/isolinux/initrd.img

3.Observe message "Unable to read package metadata"  (Screen image attached).

4. Append the following to the "kernel" line, and it works OK:
 repo=hd:sdb1:distros/fedora/11

  
Actual results:

Need "repo" line.


Expected results:

Should not need "repo" line.

Additional info: I had the same problem in Fedora 10.
Comment 1 Harry Dolan 2009-02-19 11:11:03 EST
Created attachment 332578 [details]
Screen shot of error message
Comment 2 Chris Lumens 2009-02-19 11:18:31 EST
Please attach your kickstart file to this bug report.  You can leave out any sensitive information.  The most important part is the method line.
Comment 3 Harry Dolan 2009-02-19 11:30:38 EST
Created attachment 332584 [details]
Kickstart file
Comment 4 Chris Lumens 2009-02-20 14:33:38 EST
Hm yes, this definitely seems like it should be working.  Can you also attach /tmp/anaconda.log to this bug report?  Thanks.
Comment 5 Harry Dolan 2009-02-25 12:38:49 EST
Created attachment 333191 [details]
/tmp/anaconda.log file
Comment 6 Michael Price 2009-03-04 14:51:50 EST
This bug has been triaged
Comment 7 Chris Lumens 2009-03-26 15:05:11 EDT
Oh, I think what's wrong here is the i386 -> i586 change, which resulted in all the media installs no longer working since the arch in the .discinfo file no longer matched the architecture of the machine.  Can you please try again with the beta and let me know?  I've fixed that particular problem so if I'm right, it'll fix your bug up too.

Note You need to log in before you can comment on or make changes to this bug.