Bug 486408 - GFS: gfs_grow causes lots of locking traffic
GFS: gfs_grow causes lots of locking traffic
Status: CLOSED DUPLICATE of bug 485451
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs-kmod (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Robert Peterson
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-19 11:56 EST by Nate Straz
Modified: 2010-01-11 22:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 14:01:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nate Straz 2009-02-19 11:56:36 EST
Description of problem:

When gfs_grow is running, the locking traffic is significant enough to make dlm_send look like it's spinning and the system becomes less responsive.  This load seems excessive.

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
11539 root      15  -5     0    0    0 R 59.4  0.0  92:30.65 dlm_send
11441 root      RT   0  132m  36m 2120 S 10.0  0.7  35:46.25 aisexec
 4620 root      18   0  6444 3216  460 R  4.1  0.1   1:06.08 gfs_grow

Version-Release number of selected component (if applicable):
kmod-gfs-0.1.31-3.el5
kernel-2.6.18-129.gfs2abhi.001
gfs-utils-0.1.18-1.el5
gfs2-utils-0.1.53-1.el5_3.1

How reproducible:
Every time

Steps to Reproduce:
1. Run growfs test
2. watch top
  
Actual results:


Expected results:


Additional info:
Comment 1 Robert Peterson 2009-04-01 14:01:07 EDT
The locking traffic is what was slowing down gfs_grow in bug #485451,
and the solution in bug #485451 is to reduce the locking traffic by
combining writes.  Therefore, I'm closing this bug as a duplicate.

*** This bug has been marked as a duplicate of bug 485451 ***

Note You need to log in before you can comment on or make changes to this bug.