Bug 486410 - sensors-detect spews uninitialized value warnings
sensors-detect spews uninitialized value warnings
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lm_sensors (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-19 12:01 EST by David Kovalsky
Modified: 2014-03-31 19:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-16 04:19:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kovalsky 2009-02-19 12:01:12 EST
[root@kovy ~]# sensors-detect 
# sensors-detect revision 5337 (2008-09-19 17:05:28 +0200)

This program will help you determine which kernel modules you need
to load to use lm_sensors most effectively. It is generally safe  
and recommended to accept the default answers to all questions,   
unless you know what you're doing.                                

We can start with probing for (PCI) I2C or SMBus adapters.
Do you want to probe now? (YES/no):                       
Probing for PCI bus adapters...                           
Use driver `i2c-i801' for device 0000:00:1f.3: Intel 82801G ICH7

We will now try to load each adapter module in turn.
Module `i2c-i801' already loaded.                   
If you have undetectable or unsupported I2C/SMBus adapters, you can have
them scanned by manually loading the modules before running this script.

Use of uninitialized value in string eq at /usr/sbin/sensors-detect line 2441.
Use of uninitialized value $_[0] in pattern match (m//) at /usr/sbin/sensors-detect line 2717.                                                                              
Use of uninitialized value $_[0] in pattern match (m//) at /usr/sbin/sensors-detect line 2717.  

(repeated a couple of [maybe hundred] times)

I can't really tell if anything is wrong, since the hardware that I have doesn't have a supported chipset for any sensors.

lm_sensors-3.0.3-1.fc11.i386
Comment 1 Hans de Goede 2009-02-19 14:01:00 EST
Yes, known issue caused by the new perl in rawhide. This is fixed in upstream svn and upstream will do a new release soon.

When that new release is done I'll update our package. In the mean time I'll asign this to me.
Comment 2 Hans de Goede 2009-04-16 04:19:07 EDT
New upstream release fixing this has been pushed to rawhide a while ago, closing this.

Note You need to log in before you can comment on or make changes to this bug.