Bug 486450 - no X cursor visible with recent kernels (2.6.29-0.124 and up thru 131)
no X cursor visible with recent kernels (2.6.29-0.124 and up thru 131)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-19 15:14 EST by Steven Usdansky
Modified: 2009-03-01 10:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-01 10:48:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file for cursorless X (16.99 KB, text/plain)
2009-02-19 15:14 EST, Steven Usdansky
no flags Details
xorg.conf file; ok with kernel-2.6.29-0.73, doesn't work with kernel-2.6.27-0.131 (1.92 KB, text/plain)
2009-02-19 15:16 EST, Steven Usdansky
no flags Details

  None (edit)
Description Steven Usdansky 2009-02-19 15:14:25 EST
Created attachment 332633 [details]
Xorg log file for cursorless X

Description of problem:
I'm not sure if this is the proper component against which to file this bug, but with recent kernels (going back at least as far as 2.6.29-0.124), I get no X cursor visible. 

Version-Release number of selected component (if applicable):
kernel-PAE-2.6.29-0.131.rc5.git2.fc11.i686
xorg-x11-drv-i810-2.6.0-6.fc11.i586

How reproducible:
100% of the time

Steps to Reproduce:
1. Boot into runlevel 3
2. run startx
3.
  
Actual results:
X and GNOME come up as expected, except that no X cursor is visible. If I mouseover a file or folder on my desktop, it is highlighted, but still no cursor.

Expected results:
a visible cursor when X starts

Additional info:
from lspci: VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device (rev 03)
reverting to kernel-2.6.29-0.73.rc3.git2.fc11.i686 causes everything to work properly. I use an xorg.conf file in order to obtain 1680x1050 resolution on my screen (with a modeline and Option NoAccel True); without xorg.conf I get choices of 800x600 and 640x480.
Comment 1 Steven Usdansky 2009-02-19 15:16:41 EST
Created attachment 332634 [details]
xorg.conf file; ok with kernel-2.6.29-0.73, doesn't work with kernel-2.6.27-0.131
Comment 2 Steven Usdansky 2009-03-01 10:48:51 EST
Appears to be fixed by installing hal-0.5.12-22.20090226git.fc11.i586.

Note You need to log in before you can comment on or make changes to this bug.