Bug 486460 - Don't use versioned names for .desktop files
Don't use versioned names for .desktop files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-19 16:00 EST by Milan Bouchet-Valat
Modified: 2009-02-26 11:34 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-26 06:50:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Bouchet-Valat 2009-02-19 16:00:24 EST
.desktop files for openoffice.org are named openoffice-VERSION-writer.desktop, openoffice-VERSION-calc.desktop and so on. This is a problem when you want to refer to a particular application from its .desktop file, since you cannot know where it what its name will be. OpenOffice.org is one of the only apps to use versioned .desktop filenames, and that's wrong.

In the new GNOME Shell project, we use .desktop filenames as identifiers for applications (GIO is very close to this, too), and that works well except for OO.o. It would be really good to remove versions from .desktop filenames, else some patching will be needed for each Fedora version (and cause headaches to people using development versions).

Looking at the .spec file for the openoffice.org package on Fedora's CVS, I found this line among similar others:
find . -name "*office.org$PRODUCTVERSIONSHORT*" -exec bash -c \   "mv \$1 \`echo \$1 | sed s/.org$PRODUCTVERSIONSHORT/.org/\`" -- {} \; 

This would basically do the trick if it did not apply only to icons. I don't really master .spec files syntax, but I guess from that you can easily solve this bug. Just searching for ".desktop" in the code gives some interesting results. And icon files are renamed to remove versioning, according to inline comments.


Thanks for your work! (at the same time, I'm trying to get Ubuntu to move from their own convention so that we get some kind of standardization)
Comment 1 Caolan McNamara 2009-02-19 18:16:15 EST
They're not actually versioned really, they are always 1.9, e.g. 
openoffice.org-1.9-writer.desktop
because the error was made a load of fedora versions ago to use a version, and for backwards compatibility the version was kept from there onwards.

Best thing is probably to provide an unversioned one, and if needs be link the legacy 1.9 ones to tose.
Comment 2 Caolan McNamara 2009-02-19 18:47:49 EST
Not sure if there's any existing need to keep 1.9 for the .desktops. I think the *launcher* was the problem, and we retain the silly openoffice.org-1.9 openoffice.org-2.0 ones, so should be good.
Comment 3 Milan Bouchet-Valat 2009-02-26 11:34:46 EST
Thanks! I'm not sure we'll be able to use them eventually, since I've asked on freedesktop.org list about that, and we may not be allowed to rely on filenames. Don't know what we'll do, but this fix is good to have anyway...

Note You need to log in before you can comment on or make changes to this bug.