Bug 486486 - DMA error in b43 driver
DMA error in b43 driver
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-19 18:20 EST by antserg
Modified: 2009-06-21 03:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-17 12:12:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test patches (520 bytes, application/gzip)
2009-03-03 07:36 EST, Michael Buesch
no flags Details

  None (edit)
Description antserg 2009-02-19 18:20:44 EST
Description of problem:
I'm using a WiFi pccard based on Broadcom 4319; at first connection is unstable (a lot of firmware reset after DMA error, loosing encryption keys) and it always produces fatal DMA error during scan for AP.
After some time, not always the same, it stabilizes and it works normally, as long as scan for AP is disabled.

Version-Release number of selected component (if applicable):
up to kernel-2.6.27.12-78.2.8.fc9.i686 but it is there since b43 module was released

How reproducible:
Always

Steps to Reproduce:
1. Connect the pcmcia card
2. Connect to wifi network with NetworkManager
  
Actual results:
Feb 13 07:31:03 darwin kernel: input: b43-phy0 as /devices/virtual/input/input10
Feb 13 07:31:03 darwin kernel: firmware: requesting b43/ucode5.fw
Feb 13 07:31:03 darwin kernel: firmware: requesting b43/pcm5.fw
Feb 13 07:31:04 darwin kernel: firmware: requesting b43/b0g0initvals5.fw
Feb 13 07:31:04 darwin kernel: firmware: requesting b43/b0g0bsinitvals5.fw
Feb 13 07:31:04 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Feb 13 07:31:04 darwin kernel: Registered led device: b43-phy0::tx
Feb 13 07:31:04 darwin kernel: Registered led device: b43-phy0::rx
Feb 13 07:31:04 darwin kernel: Registered led device: b43-phy0::radio
Feb 13 07:31:04 darwin kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Feb 13 07:31:04 darwin NetworkManager: <info>  (wlan0): preparing device.
Feb 13 07:31:04 darwin NetworkManager: <info>  (wlan0): deactivating device (reason: 2).
Feb 13 07:31:04 darwin NetworkManager: <info>  (wlan0): device state change: 2 -> 3
Feb 13 07:31:04 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Feb 13 07:31:04 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Feb 13 07:31:04 darwin NetworkManager: <info>  (wlan0): supplicant interface state:  starting -> ready
Feb 13 07:31:05 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Feb 13 07:31:05 darwin kernel: Registered led device: b43-phy0::tx
Feb 13 07:31:05 darwin kernel: Registered led device: b43-phy0::rx
Feb 13 07:31:05 darwin kernel: Registered led device: b43-phy0::radio
Feb 13 07:31:05 darwin kernel: b43-phy0: Controller restarted
Feb 13 07:31:05 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Feb 13 07:31:05 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Feb 13 07:31:05 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Feb 13 07:31:05 darwin kernel: Registered led device: b43-phy0::tx
Feb 13 07:31:05 darwin kernel: Registered led device: b43-phy0::rx
Feb 13 07:31:05 darwin kernel: Registered led device: b43-phy0::radio
Feb 13 07:31:05 darwin kernel: b43-phy0: Controller restarted


Expected results:


Additional info:
The workaround is to modify NetworkManager to avoid scan for APs when connected and supply the encryption key at any firmware restart till the connection becomes stable.
Since this problem is not mentioned anywhere, maybe it is not known and it never be solved.
Comment 1 Chuck Ebbert 2009-02-19 18:42:44 EST
Can you try 2.6.27.15-170.2.24.fc10 ?
Comment 2 antserg 2009-02-21 13:23:21 EST
I will be able to do that in few days (I've not that hardware with me).
Comment 3 antserg 2009-02-25 03:46:44 EST
I tried kernel-2.6.27.5-117.fc10.i686.rpm from live cd and it has the same problem; to try the version you suggested I should update several packages (like udev and initscripts) which makes me afraid to fall in compatibility problems with
the fc9 installation I'm using (for working every day).
If you think there could really be a difference using 2.6.27.15-170.2.24.fc10, I could spend some time to upgrade the whole OS, but it will take some time.
Comment 4 antserg 2009-02-27 01:38:38 EST
I did it, even if I was sure it would have changed nothing; I upgraded to fedora 10 and installed kernel 2.6.27.15-170.2.24.fc10 as you suggested, but the phenomenology is exactly the same; anyhow, I gained a speedup in boot time.

I noticed that the chipset id bcm4318, not bcm4319 as mentioned in the first message; sorry for the mistake.

Feb 26 20:05:03 darwin kernel: pccard: CardBus card inserted into slot 0
Feb 26 20:05:03 darwin kernel: b43-pci-bridge 0000:02:00.0: enabling device (0000 -> 0002)
Feb 26 20:05:03 darwin kernel: b43-pci-bridge 0000:02:00.0: PCI INT A -> Link[LNKB] -> GSI 5 (level, low) -> IRQ 5
Feb 26 20:05:03 darwin kernel: ssb: Sonics Silicon Backplane found on PCI device 0000:02:00.0
Feb 26 20:05:04 darwin kernel: b43-phy0: Broadcom 4318 WLAN found
Feb 26 20:05:04 darwin kernel: Broadcom 43xx driver loaded [ Features: PMLR, Firmware-ID: FW13 ]
Feb 26 20:05:05 darwin NetworkManager: <info>  wlan0: driver is 'b43-pci-bridge'.
Feb 26 20:05:05 darwin NetworkManager: <info>  wlan0: driver supports SSID scans (scan_capa 0x01).
Feb 26 20:05:05 darwin NetworkManager: <info>  Found new 802.11 WiFi device 'wlan0'.
Feb 26 20:05:05 darwin NetworkManager: <info>  (wlan0): exported as /org/freedesktop/Hal/devices/net_00_18_f8_d9_78_cd_0
Feb 26 20:05:09 darwin NetworkManager: <info>  (wlan0): device state change: 1 -> 2
Feb 26 20:05:09 darwin NetworkManager: <info>  (wlan0): bringing up device.
Feb 26 20:05:09 darwin kernel: input: b43-phy0 as /devices/virtual/input/input10
Feb 26 20:05:09 darwin kernel: firmware: requesting b43/ucode5.fw
Feb 26 20:05:09 darwin kernel: firmware: requesting b43/pcm5.fw
Feb 26 20:05:09 darwin kernel: firmware: requesting b43/b0g0initvals5.fw
Feb 26 20:05:09 darwin kernel: firmware: requesting b43/b0g0bsinitvals5.fw
Feb 26 20:05:10 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Feb 26 20:05:10 darwin kernel: Registered led device: b43-phy0::tx
Feb 26 20:05:10 darwin kernel: Registered led device: b43-phy0::rx
Feb 26 20:05:10 darwin kernel: Registered led device: b43-phy0::radio
Feb 26 20:05:10 darwin kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Feb 26 20:05:10 darwin NetworkManager: <info>  (wlan0): preparing device.
Feb 26 20:05:10 darwin NetworkManager: <info>  (wlan0): deactivating device (reason: 2).
Feb 26 20:05:10 darwin NetworkManager: <info>  (wlan0): device state change: 2 -> 3
Feb 26 20:05:10 darwin kernel: AR5210, AR5211, AR5212, AR5416, RF5111, RF5112, RF2413, RF5413, RF2133, RF2425, RF2417)
Feb 26 20:05:10 darwin kernel: __ratelimit: 4 callbacks suppressed
Feb 26 20:05:10 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Feb 26 20:05:10 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Feb 26 20:05:10 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Feb 26 20:05:11 darwin NetworkManager: <info>  (wlan0): supplicant interface state:  starting -> ready
Feb 26 20:05:11 darwin kernel: Registered led device: b43-phy0::tx
Feb 26 20:05:11 darwin kernel: Registered led device: b43-phy0::rx
Feb 26 20:05:11 darwin kernel: Registered led device: b43-phy0::radio
Feb 26 20:05:11 darwin kernel: b43-phy0: Controller restarted
F
Comment 5 John W. Linville 2009-03-02 11:52:13 EST
It is interesting that the scan for APs is linked with the Fatal DMA error.  Perhaps there is something (else) in b43 that could utilize the new software scan callbacks?
Comment 6 antserg 2009-03-02 12:38:00 EST
(In reply to comment #5)
> It is interesting that the scan for APs is linked with the Fatal DMA error. 
> Perhaps there is something (else) in b43 that could utilize the new software
> scan callbacks?

The DMA error is also related to network traffic for few minutes after the connection is completed; my guess is that it has something to do with RF power adjustments, but I cannot say it for sure. The trick I use to make it stabilize is to ping the AP continuously and supply the WEP KEY after each DMA error, while other applications try to use the network. It can take several minutes (1-10) to become stable.
I do not know if this is a useful information.
Comment 7 Michael Buesch 2009-03-02 12:48:55 EST
The DMA error code 0x1000 "Descriptor protocol error" inticates that you have problems with DMA write posting.

What architecture are you running?

You can try changing the memory barrier in dma.c:

1228         /* Now transfer the whole frame. */
1229         wmb();
1230         ops->poke_tx(ring, next_slot(ring, slot));
1231         return 0;


Try to use mb() instead of wmb(). If that doesn't help, try to use udelay(50);
Comment 8 Michael Buesch 2009-03-03 07:36:24 EST
Created attachment 333870 [details]
Test patches

Here's a bunch of test patches. Please apply them on top of each other in-order (first 001 then 002 and then 003) and test after _each_ patch if the problem still exists.
Comment 9 John W. Linville 2009-03-03 09:24:48 EST
antserg, are you able to build kernels for testing as Michael requested?  Or do you need assistance?
Comment 10 antserg 2009-03-03 09:45:58 EST
About the architecture:
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 10
model name      : Mobile AMD Athlon(tm) XP 2400+

the kernel I'm using now:
2.6.27.15-170.2.24.fc10.i686 #1 SMP Wed Feb 11 23:58:12 EST 2009 i686 athlon i386 GNU/Linux

For kernel compiling ... well ... I think I have not been compiling a kernel since Fedora Core 1 has been released, or something like that ... maybe earlier;
if what I need is:
download kernel-2.6.27.15-170.2.24.fc10.src.rpm or similar
make xconfig or qconfig or whatever
load /boot/config.2.6.27.15-170.2.24.fc10.i686
save and exit
make modules

I think I should have no problem, but it's just a matter of time; if there are significant changes in the procedure, or there is an easy way to compile a restricted part of the source code (of course with the same version flags of the compiled kernel), I could use some suggestions.

Thank you
Comment 11 John W. Linville 2009-03-03 10:02:03 EST
It sounds like you understand the process.  Don't forget the part about applying Michael's patches and rebuilding! :-)
Comment 12 antserg 2009-03-04 03:15:11 EST
I tried with 2.6.27.19-170.2.35.fc10.i686 (the first src I found); after each pccard insertion (module load) I issued an iwlist scan.



patch 001)

Mar  4 08:31:58 darwin kernel: pccard: CardBus card inserted into slot 0
Mar  4 08:31:58 darwin kernel: b43-pci-bridge 0000:02:00.0: enabling device (0000 -> 0002)
Mar  4 08:31:58 darwin kernel: b43-pci-bridge 0000:02:00.0: PCI INT A -> Link[LNKB] -> GSI 5 (level, low) -> IRQ 5
Mar  4 08:31:58 darwin kernel: ssb: Sonics Silicon Backplane found on PCI device 0000:02:00.0
Mar  4 08:31:59 darwin kernel: b43-phy0: Broadcom 4318 WLAN found
Mar  4 08:31:59 darwin kernel: Broadcom 43xx driver loaded [ Features: PMLR, Firmware-ID: FW13 ]
Mar  4 08:31:59 darwin NetworkManager: <info>  wlan0: driver is 'b43-pci-bridge'.
Mar  4 08:31:59 darwin NetworkManager: <info>  wlan0: driver supports SSID scans (scan_capa 0x01).
Mar  4 08:31:59 darwin NetworkManager: <info>  Found new 802.11 WiFi device 'wlan0'.
Mar  4 08:31:59 darwin NetworkManager: <info>  (wlan0): exported as /org/freedesktop/Hal/devices/net_00_18_f8_d9_78_cd_0
Mar  4 08:32:03 darwin NetworkManager: <info>  (wlan0): device state change: 1 -> 2
Mar  4 08:32:03 darwin NetworkManager: <info>  (wlan0): bringing up device.
Mar  4 08:32:03 darwin kernel: input: b43-phy0 as /devices/virtual/input/input10
Mar  4 08:32:03 darwin kernel: firmware: requesting b43/ucode5.fw
Mar  4 08:32:03 darwin kernel: firmware: requesting b43/pcm5.fw
Mar  4 08:32:04 darwin kernel: firmware: requesting b43/b0g0initvals5.fw
Mar  4 08:32:04 darwin kernel: firmware: requesting b43/b0g0bsinitvals5.fw
Mar  4 08:32:04 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 08:32:04 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 08:32:04 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 08:32:04 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 08:32:04 darwin kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Mar  4 08:32:04 darwin NetworkManager: <info>  (wlan0): preparing device.
Mar  4 08:32:04 darwin NetworkManager: <info>  (wlan0): deactivating device (reason: 2).
Mar  4 08:32:04 darwin NetworkManager: <info>  Policy set 'Auto eth0' (eth0) as default for routing and DNS.
Mar  4 08:32:04 darwin NetworkManager: <info>  (wlan0): device state change: 2 -> 3
Mar  4 08:32:04 darwin kernel: __ratelimit: 4 callbacks suppressed
Mar  4 08:32:04 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 08:32:04 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Mar  4 08:32:04 darwin kernel: AR5210, AR5211, AR5212, AR5416, RF5111, RF5112, RF2413, RF5413, RF2133, RF2425, RF2417)
Mar  4 08:32:05 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 08:32:05 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 08:32:05 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 08:32:05 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 08:32:05 darwin kernel: b43-phy0: Controller restarted
Mar  4 08:32:05 darwin NetworkManager: <info>  (wlan0): supplicant interface state:  starting -> ready
Mar  4 08:32:05 darwin kernel: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Mar  4 08:32:05 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 08:32:05 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Mar  4 08:32:05 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 08:32:05 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 08:32:05 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 08:32:05 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 08:32:05 darwin kernel: b43-phy0: Controller restarted
Mar  4 08:32:21 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 08:32:21 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Mar  4 08:32:21 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 08:32:21 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 08:32:21 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 08:32:21 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 08:32:21 darwin kernel: b43-phy0: Controller restarted
Mar  4 08:32:21 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 08:32:21 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Mar  4 08:32:21 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 08:32:21 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 08:32:21 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 08:32:21 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 08:32:21 darwin kernel: b43-phy0: Controller restarted
Mar  4 08:32:25 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 08:32:25 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Mar  4 08:32:25 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 08:32:25 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 08:32:25 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 08:32:25 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 08:32:25 darwin kernel: b43-phy0: Controller restarted
Mar  4 08:32:25 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 08:32:26 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 08:32:26 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 08:32:26 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 08:32:26 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 08:32:26 darwin kernel: __ratelimit: 1 callbacks suppressed
Mar  4 08:32:26 darwin kernel: b43-phy0: Controller restarted
Mar  4 08:32:45 darwin kernel: pccard: card ejected from slot 0
Mar  4 08:32:45 darwin kernel: b43-phy0 ERROR: DMA RX reset timed out
Mar  4 08:32:45 darwin kernel: b43-phy0 ERROR: DMA TX reset timed out
Mar  4 08:32:45 darwin kernel: b43-phy0 ERROR: DMA TX reset timed out
Mar  4 08:32:45 darwin kernel: b43-phy0 ERROR: DMA TX reset timed out
Mar  4 08:32:45 darwin kernel: b43-phy0 ERROR: DMA TX reset timed out
Mar  4 08:32:45 darwin kernel: b43-phy0 ERROR: DMA TX reset timed out
Mar  4 08:32:45 darwin kernel: ssb: Failed to switch to core 0
Mar  4 08:32:45 darwin kernel: b43-pci-bridge 0000:02:00.0: PCI INT A disabled
Mar  4 08:32:45 darwin NetworkManager: <info>  (wlan0): now unmanaged
Mar  4 08:32:45 darwin NetworkManager: <info>  (wlan0): device state change: 3 -> 1
Mar  4 08:32:45 darwin NetworkManager: <info>  (wlan0): cleaning up...



patch 001b) I noticed that at pccard insertion also ath_pci was loaded (madwifi), for (to me) unknown reasons, and I blacklisted it

Mar  4 08:35:56 darwin kernel: pccard: CardBus card inserted into slot 0
Mar  4 08:35:56 darwin kernel: b43-pci-bridge 0000:02:00.0: enabling device (0000 -> 0002)
Mar  4 08:35:56 darwin kernel: b43-pci-bridge 0000:02:00.0: PCI INT A -> Link[LNKB] -> GSI 5 (level, low) -> IRQ 5
Mar  4 08:35:56 darwin kernel: ssb: Sonics Silicon Backplane found on PCI device 0000:02:00.0
Mar  4 08:35:57 darwin kernel: b43-phy0: Broadcom 4318 WLAN found
Mar  4 08:35:57 darwin kernel: Broadcom 43xx driver loaded [ Features: PMLR, Firmware-ID: FW13 ]
Mar  4 08:35:57 darwin NetworkManager: <info>  wlan0: driver is 'b43-pci-bridge'.
Mar  4 08:35:57 darwin NetworkManager: <info>  wlan0: driver supports SSID scans (scan_capa 0x01).
Mar  4 08:35:57 darwin NetworkManager: <info>  Found new 802.11 WiFi device 'wlan0'.
Mar  4 08:35:57 darwin NetworkManager: <info>  (wlan0): exported as /org/freedesktop/Hal/devices/net_00_18_f8_d9_78_cd
Mar  4 08:36:01 darwin NetworkManager: <info>  (wlan0): device state change: 1 -> 2
Mar  4 08:36:01 darwin NetworkManager: <info>  (wlan0): bringing up device.
Mar  4 08:36:01 darwin kernel: input: b43-phy0 as /devices/virtual/input/input11
Mar  4 08:36:01 darwin kernel: firmware: requesting b43/ucode5.fw
Mar  4 08:36:02 darwin kernel: firmware: requesting b43/pcm5.fw
Mar  4 08:36:02 darwin kernel: firmware: requesting b43/b0g0initvals5.fw
Mar  4 08:36:02 darwin kernel: firmware: requesting b43/b0g0bsinitvals5.fw
Mar  4 08:36:02 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 08:36:02 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 08:36:02 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 08:36:02 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 08:36:02 darwin kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Mar  4 08:36:02 darwin NetworkManager: <info>  (wlan0): preparing device.
Mar  4 08:36:02 darwin NetworkManager: <info>  (wlan0): deactivating device (reason: 2).
Mar  4 08:36:02 darwin NetworkManager: <info>  Policy set 'Auto eth0' (eth0) as default for routing and DNS.
Mar  4 08:36:02 darwin NetworkManager: <info>  (wlan0): device state change: 2 -> 3
Mar  4 08:36:02 darwin NetworkManager: <info>  (wlan0): supplicant interface state:  starting -> ready
Mar  4 08:36:02 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 08:36:02 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Mar  4 08:36:03 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 08:36:03 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 08:36:03 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 08:36:03 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 08:36:03 darwin kernel: b43-phy0: Controller restarted
Mar  4 08:36:03 darwin kernel: b43-phy0 ERROR: PHY transmission error
Mar  4 08:36:03 darwin kernel: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Mar  4 08:36:04 darwin kernel: b43-phy0 ERROR: PHY transmission error
Mar  4 08:36:06 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 08:36:06 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Mar  4 08:36:06 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 08:36:06 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 08:36:06 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 08:36:06 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 08:36:06 darwin kernel: b43-phy0: Controller restarted
Mar  4 08:36:22 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 08:36:22 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Mar  4 08:36:23 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 08:36:23 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 08:36:23 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 08:36:23 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 08:36:23 darwin kernel: b43-phy0: Controller restarted
Mar  4 08:36:23 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 08:36:23 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Mar  4 08:36:23 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 08:36:23 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 08:36:23 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 08:36:23 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 08:36:23 darwin kernel: b43-phy0: Controller restarted
Mar  4 08:36:43 darwin kernel: pccard: card ejected from slot 0
Mar  4 08:36:43 darwin kernel: b43-phy0 ERROR: DMA RX reset timed out
Mar  4 08:36:43 darwin kernel: b43-phy0 ERROR: DMA TX reset timed out
Mar  4 08:36:43 darwin kernel: b43-phy0 ERROR: DMA TX reset timed out
Mar  4 08:36:43 darwin kernel: b43-phy0 ERROR: DMA TX reset timed out
Mar  4 08:36:43 darwin kernel: b43-phy0 ERROR: DMA TX reset timed out
Mar  4 08:36:43 darwin kernel: b43-phy0 ERROR: DMA TX reset timed out
Mar  4 08:36:43 darwin kernel: ssb: Failed to switch to core 0
Mar  4 08:36:43 darwin kernel: b43-pci-bridge 0000:02:00.0: PCI INT A disabled
Mar  4 08:36:43 darwin NetworkManager: <info>  (wlan0): now unmanaged
Mar  4 08:36:43 darwin NetworkManager: <info>  (wlan0): device state change: 3 -> 1
Mar  4 08:36:43 darwin NetworkManager: <info>  (wlan0): cleaning up...





patch 002)

Mar  4 08:55:17 darwin kernel: pccard: CardBus card inserted into slot 0
Mar  4 08:55:17 darwin kernel: b43-pci-bridge 0000:02:00.0: enabling device (0000 -> 0002)
Mar  4 08:55:17 darwin kernel: b43-pci-bridge 0000:02:00.0: PCI INT A -> Link[LNKB] -> GSI 5 (level, low) -> IRQ 5
Mar  4 08:55:17 darwin kernel: ssb: Sonics Silicon Backplane found on PCI device 0000:02:00.0
Mar  4 08:55:17 darwin kernel: b43-phy0: Broadcom 4318 WLAN found
Mar  4 08:55:17 darwin kernel: Broadcom 43xx driver loaded [ Features: PMLR, Firmware-ID: FW13 ]
Mar  4 08:55:18 darwin NetworkManager: <info>  wlan0: driver is 'b43-pci-bridge'.
Mar  4 08:55:18 darwin NetworkManager: <info>  wlan0: driver supports SSID scans (scan_capa 0x01).
Mar  4 08:55:18 darwin NetworkManager: <info>  Found new 802.11 WiFi device 'wlan0'.
Mar  4 08:55:18 darwin NetworkManager: <info>  (wlan0): exported as /org/freedesktop/Hal/devices/net_00_18_f8_d9_78_cd_0
Mar  4 08:55:22 darwin NetworkManager: <info>  (wlan0): device state change: 1 -> 2
Mar  4 08:55:22 darwin NetworkManager: <info>  (wlan0): bringing up device.
Mar  4 08:55:22 darwin kernel: input: b43-phy0 as /devices/virtual/input/input12
Mar  4 08:55:22 darwin kernel: firmware: requesting b43/ucode5.fw
Mar  4 08:55:22 darwin kernel: firmware: requesting b43/pcm5.fw
Mar  4 08:55:22 darwin kernel: firmware: requesting b43/b0g0initvals5.fw
Mar  4 08:55:22 darwin kernel: firmware: requesting b43/b0g0bsinitvals5.fw
Mar  4 08:55:22 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 08:55:22 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 08:55:22 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 08:55:22 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 08:55:22 darwin kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Mar  4 08:55:22 darwin NetworkManager: <info>  (wlan0): preparing device.
Mar  4 08:55:22 darwin NetworkManager: <info>  (wlan0): deactivating device (reason: 2).
Mar  4 08:55:23 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 08:55:23 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Mar  4 08:55:23 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 08:55:23 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 08:55:23 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 08:55:23 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 08:55:23 darwin kernel: b43-phy0: Controller restarted
Mar  4 08:55:23 darwin NetworkManager: <info>  Policy set 'Auto eth0' (eth0) as default for routing and DNS.
Mar  4 08:55:23 darwin NetworkManager: <info>  (wlan0): device state change: 2 -> 3
Mar  4 08:55:23 darwin NetworkManager: <info>  (wlan0): supplicant interface state:  starting -> ready
Mar  4 08:55:24 darwin kernel: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Mar  4 08:55:25 darwin kernel: b43-phy0 ERROR: PHY transmission error
Mar  4 08:55:26 darwin kernel: b43-phy0 ERROR: PHY transmission error
Mar  4 08:55:27 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 08:55:27 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Mar  4 08:55:27 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 08:55:27 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 08:55:27 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 08:55:27 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 08:55:27 darwin kernel: b43-phy0: Controller restarted
Mar  4 08:55:42 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 08:55:42 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Mar  4 08:55:42 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 08:55:42 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 08:55:42 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 08:55:42 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 08:55:42 darwin kernel: b43-phy0: Controller restarted
Mar  4 08:55:43 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 08:55:43 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Mar  4 08:55:43 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 08:55:43 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 08:55:43 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 08:55:43 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 08:55:43 darwin kernel: b43-phy0: Controller restarted
Mar  4 08:55:43 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 08:55:43 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Mar  4 08:55:43 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 08:55:43 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 08:55:43 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 08:55:43 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 08:55:43 darwin kernel: b43-phy0: Controller restarted
Mar  4 08:55:44 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 08:55:44 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 08:55:44 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 08:55:44 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 08:55:44 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 08:56:13 darwin kernel: __ratelimit: 2 callbacks suppressed
Mar  4 08:56:13 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 08:56:13 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Mar  4 08:56:14 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 08:56:14 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 08:56:14 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 08:56:14 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 08:56:14 darwin kernel: b43-phy0: Controller restarted
Mar  4 08:56:14 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 08:56:14 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Mar  4 08:56:14 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 08:56:14 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 08:56:14 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 08:56:14 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 08:56:14 darwin kernel: b43-phy0: Controller restarted
Mar  4 08:56:53 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 08:56:53 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Mar  4 08:56:54 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 08:56:54 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 08:56:54 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 08:56:54 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 08:56:54 darwin kernel: b43-phy0: Controller restarted
Mar  4 08:56:54 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 08:56:54 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Mar  4 08:56:54 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 08:56:54 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 08:56:54 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 08:56:54 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 08:56:54 darwin kernel: b43-phy0: Controller restarted
Mar  4 08:57:00 darwin kernel: b43-pci-bridge 0000:02:00.0: PCI INT A disabled
Mar  4 08:57:00 darwin NetworkManager: <info>  (wlan0): now unmanaged
Mar  4 08:57:00 darwin NetworkManager: <info>  (wlan0): device state change: 3 -> 1
Mar  4 08:57:00 darwin NetworkManager: <info>  (wlan0): cleaning up...
Mar  4 08:57:05 darwin kernel: pccard: card ejected from slot 0






patch 003)

Mar  4 09:06:01 darwin kernel: pccard: CardBus card inserted into slot 0
Mar  4 09:06:02 darwin kernel: b43-pci-bridge 0000:02:00.0: enabling device (0000 -> 0002)
Mar  4 09:06:02 darwin kernel: b43-pci-bridge 0000:02:00.0: PCI INT A -> Link[LNKB] -> GSI 5 (level, low) -> IRQ 5
Mar  4 09:06:02 darwin kernel: ssb: Sonics Silicon Backplane found on PCI device 0000:02:00.0
Mar  4 09:06:02 darwin kernel: b43-phy0: Broadcom 4318 WLAN found
Mar  4 09:06:02 darwin kernel: Broadcom 43xx driver loaded [ Features: PMLR, Firmware-ID: FW13 ]
Mar  4 09:06:03 darwin NetworkManager: <info>  wlan0: driver is 'b43-pci-bridge'.
Mar  4 09:06:03 darwin NetworkManager: <info>  wlan0: driver supports SSID scans (scan_capa 0x01).
Mar  4 09:06:03 darwin NetworkManager: <info>  Found new 802.11 WiFi device 'wlan0'.
Mar  4 09:06:03 darwin NetworkManager: <info>  (wlan0): exported as /org/freedesktop/Hal/devices/net_00_18_f8_d9_78_cd_0
Mar  4 09:06:07 darwin NetworkManager: <info>  (wlan0): device state change: 1 -> 2
Mar  4 09:06:07 darwin NetworkManager: <info>  (wlan0): bringing up device.
Mar  4 09:06:07 darwin kernel: input: b43-phy0 as /devices/virtual/input/input13
Mar  4 09:06:07 darwin kernel: firmware: requesting b43/ucode5.fw
Mar  4 09:06:07 darwin kernel: firmware: requesting b43/pcm5.fw
Mar  4 09:06:07 darwin kernel: firmware: requesting b43/b0g0initvals5.fw
Mar  4 09:06:07 darwin kernel: firmware: requesting b43/b0g0bsinitvals5.fw
Mar  4 09:06:08 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 09:06:08 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 09:06:08 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 09:06:08 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 09:06:08 darwin kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Mar  4 09:06:08 darwin NetworkManager: <info>  (wlan0): preparing device.
Mar  4 09:06:08 darwin NetworkManager: <info>  (wlan0): deactivating device (reason: 2).
Mar  4 09:06:08 darwin NetworkManager: <info>  Policy set 'Auto eth0' (eth0) as default for routing and DNS.
Mar  4 09:06:08 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 09:06:08 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Mar  4 09:06:08 darwin NetworkManager: <info>  (wlan0): device state change: 2 -> 3
Mar  4 09:06:08 darwin NetworkManager: <info>  (wlan0): supplicant interface state:  starting -> ready
Mar  4 09:06:08 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 09:06:08 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 09:06:08 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 09:06:08 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 09:06:08 darwin kernel: b43-phy0: Controller restarted
Mar  4 09:06:09 darwin kernel: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Mar  4 09:06:12 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 09:06:12 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Mar  4 09:06:12 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 09:06:12 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 09:06:12 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 09:06:12 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 09:06:12 darwin kernel: b43-phy0: Controller restarted
Mar  4 09:06:19 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 09:06:19 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Mar  4 09:06:19 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 09:06:20 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 09:06:20 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 09:06:20 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 09:06:20 darwin kernel: b43-phy0: Controller restarted
Mar  4 09:06:20 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 09:06:20 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Mar  4 09:06:20 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 09:06:20 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 09:06:20 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 09:06:20 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 09:06:20 darwin kernel: b43-phy0: Controller restarted
Mar  4 09:06:28 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 09:06:28 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Mar  4 09:06:28 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 09:06:28 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 09:06:28 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 09:06:28 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 09:06:28 darwin kernel: b43-phy0: Controller restarted
Mar  4 09:06:29 darwin kernel: b43-phy0 ERROR: Fatal DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000
Mar  4 09:06:29 darwin kernel: b43-phy0: Controller RESET (DMA error) ...
Mar  4 09:06:29 darwin kernel: b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
Mar  4 09:06:29 darwin kernel: Registered led device: b43-phy0::tx
Mar  4 09:06:29 darwin kernel: Registered led device: b43-phy0::rx
Mar  4 09:06:29 darwin kernel: Registered led device: b43-phy0::radio
Mar  4 09:06:29 darwin kernel: b43-phy0: Controller restarted
Mar  4 09:06:35 darwin kernel: pccard: card ejected from slot 0
Mar  4 09:06:35 darwin kernel: b43-phy0: Radio hardware status changed to DISABLED
Mar  4 09:06:35 darwin kernel: b43-phy0 ERROR: DMA RX reset timed out
Mar  4 09:06:35 darwin kernel: b43-phy0 ERROR: DMA TX reset timed out
Mar  4 09:06:35 darwin kernel: b43-phy0 ERROR: DMA TX reset timed out
Mar  4 09:06:35 darwin kernel: b43-phy0 ERROR: DMA TX reset timed out
Mar  4 09:06:35 darwin kernel: b43-phy0 ERROR: DMA TX reset timed out
Mar  4 09:06:35 darwin kernel: b43-phy0 ERROR: DMA TX reset timed out
Mar  4 09:06:35 darwin kernel: ssb: Failed to switch to core 0
Mar  4 09:06:35 darwin kernel: b43-pci-bridge 0000:02:00.0: PCI INT A disabled
Mar  4 09:06:36 darwin NetworkManager: <info>  (wlan0): now unmanaged
Mar  4 09:06:36 darwin NetworkManager: <info>  (wlan0): device state change: 3 -> 1
Mar  4 09:06:36 darwin NetworkManager: <info>  (wlan0): cleaning up...
Comment 13 Michael Buesch 2009-03-04 09:35:10 EST
Ok, thanks for testing.
I tend to say that this is a hardware issue.
Is it possible to replace the card and/or try the card in another machine?
Comment 14 antserg 2009-03-04 10:02:08 EST
(In reply to comment #13)
> Ok, thanks for testing.
> I tend to say that this is a hardware issue.
> Is it possible to replace the card and/or try the card in another machine?

I never had problems using it under winxp (connection/disconnection ... instabilities, as far as it is visible in such environment) with its original driver, even if I rarely use winxp, so I guess the hardware is fine.

For trying in another machine, it is not easy to do it (I have not another laptop with pccard slot), but not impossible.
Comment 15 Michael Buesch 2009-03-04 10:21:49 EST
Well, this would not be the first time that a bcm43 card shows bad behaviour in certain machines under Linux.

The thing is: The DMA engine is understood pretty well and we have good documentation for it. The code works since lots of years unchanged as-is.
The "descriptor protocol error" means that the card receives garbage data through DMA. That could possibly happen due to write posting problems. But this is unlikely, because the code works since ever. (And we tested by adding heavier barriers).

That the problems goes away after some time also indicates to me that something fishy is going on. The descriptors are always set up in exactly the same way, so I cannot see how a bug could suddenly disappear after some runtime.

And if you say you never had connection instabilities in windows, I'd like you to retest and look a little bit closer.
I'm pretty sure that the broadcom wl driver does reassociate and setup the keys after a DMA reset. So you won't notice a DMA reset that easily. In fact, if you're not transferring a bulk of data you most likely won't notice it at all. If you're transferring a large file you might notice an interruption of one or two seconds.

b43 does _not_ redo the key setup and reassoc on a DMA failure. So it's up to the supplicant to detect this. This requires several timeouts to be hit, so it might take some time.
We might change that in future, but for now it's not easily possible, because it needs mac80211 support.

So in the end I'd like to close this bug as we can't do anything about it.
Comment 16 antserg 2009-03-04 11:42:33 EST
I see; within few days I could try the data transfer under win, but your interpretation seems reasonable (furthermore I never used win for working, so, no need to complain).

Well. I leave to you the decision if closing or not the bug; I can leave with my workaround, so if the problem is only mine and with no solution ...

Thank you
Comment 17 antserg 2009-03-09 04:52:24 EDT
I did some testing under winxp to check the hypothesis of a hardware problem:
I started a data transfer immediately after pccard insertion, checking the rate by the task manager, and requesting several time a scan for APs; I did not notice any drop in the data rate.
I'm not sure this means that there is no hardware problem of course, but I could not see any effect.

Going back to linux, I noticed a difference in DMA errors I didn't mentioned before:
a scan request produces, always, no matter what (connected, not connected, connection stable since hours or seconds)

DMA error: 0x00000000, 0x00000000, 0x00000000, 0x00001000, 0x00000000, 0x00000000

while
DMA error: 0x00000000, 0x00001000, 0x00000000, 0x00000000, 0x00000000, 0x00000000

occurs when the previous one ha destabilized the connection

I do not know if this has a particular meaning or not, but I think it was worth to mention it.

Another thing to mention is that from time to time, very rarely (that's why I forgot to mention it before), such problems seem less severe, meaning that after the first DMA error the system is stable and, after supplying the key, everything works fine; I always thought it was some timing effect, but without actually knowing the details of the implementation.

A similar behaviour was already there when I was using bcm43xx; if it is of any help, the workaround there was to unload and reload the module till it didn't show any DMA error, and, in that case, there was also the fact that, once stabilized, it was also possible to scan without problems (another thing I forgot). But this was true only for some earlier versions of bcm43xx; after some updgrade (I do not remember when, but probably short before b43 was released) it became impossible to use the card.

I hope this is useful
Comment 18 John W. Linville 2009-06-17 12:12:29 EDT
Closing on basis of comment 15...
Comment 19 Schipper Sjoerd 2009-06-21 03:51:51 EDT
Just to let you know, I experience the exact same problem. I use several (3) different broadcom-based pcmcia wlan-cards without any problems whatsoever on Ubuntu 9.*, fedora 10/11, windows xp and 7 on my IBM Thinkpad a31. Once I try to use them in my Acer Aspire 1350 they all fail with the reported errors.

Note You need to log in before you can comment on or make changes to this bug.