Bug 486492 - Cannot install eclipse-platform due to too new tomcat5 packages in repository
Cannot install eclipse-platform due to too new tomcat5 packages in repository
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: tomcat5 (Show other bugs)
9
i386 Linux
low Severity high
: ---
: ---
Assigned To: David Walluck
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-19 18:43 EST by Dirk Hoffmann
Modified: 2009-07-14 13:54 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 13:54:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dirk Hoffmann 2009-02-19 18:43:21 EST
Description of problem:


Version-Release number of selected component (if applicable):

I tried to install eclipse-platform.i386 1:3.3.2-11.fc9 from the "fedora" repository.

How reproducible: 100%

Steps to Reproduce:
1. (sudo) yum install fedora-platform
  ... ends up with a depency problem for tomcat5-common-lib-5.5.26-1jpp.2.fc9.i386, as follows:

--> Résolution des dépendances terminée
tomcat5-common-lib-5.5.26-1jpp.2.fc9.i386 de fedora a des problèmes de dépendances
  --> Dépendance manquante : tomcat5-servlet-2.4-api = 5.5.26-1jpp.2.fc9 est requis par le paquetage tomcat5-common-lib-5.5.26-1jpp.2.fc9.i386 (fedora)
tomcat5-jasper-5.5.26-1jpp.2.fc9.i386 de fedora a des problèmes de dépendances
  --> Dépendance manquante : tomcat5-servlet-2.4-api = 5.5.26-1jpp.2.fc9 est requis par le paquetage tomcat5-jasper-5.5.26-1jpp.2.fc9.i386 (fedora)
tomcat5-common-lib-5.5.26-1jpp.2.fc9.i386 de fedora a des problèmes de dépendances
  --> Dépendance manquante : tomcat5-jsp-2.0-api = 5.5.26-1jpp.2.fc9 est requis par le paquetage tomcat5-common-lib-5.5.26-1jpp.2.fc9.i386 (fedora)
Erreur : Dépendance manquante : tomcat5-servlet-2.4-api = 5.5.26-1jpp.2.fc9 est requis par le paquetage tomcat5-common-lib-5.5.26-1jpp.2.fc9.i386 (fedora)
Erreur : Dépendance manquante : tomcat5-jsp-2.0-api = 5.5.26-1jpp.2.fc9 est requis par le paquetage tomcat5-common-lib-5.5.26-1jpp.2.fc9.i386 (fedora)
Erreur : Dépendance manquante : tomcat5-servlet-2.4-api = 5.5.26-1jpp.2.fc9 est requis par le paquetage tomcat5-jasper-5.5.26-1jpp.2.fc9.i386 (fedora)

2. That's it!
  
Actual results:

Dependency problems with tomcat5 packages that apparently have been replaced by newer versions in the repository (AND changed package name tomcat5->tomcat6):

tomcat5-servlet-2.4-api = 5.5.26-1jpp.2.fc9 -> 5.5.27-0jpp.2.fc9
tomcat5-jsp-2.0-api = 5.5.26-1jpp.2.fc9 -> 5.5.27-0jpp.2.fc9

Expected results:

Is there a chance the yum repository (or the package depencency definitions in tomcat5-common-lib-5.5.26-1jpp.2.fc9.i386?) can be modified to accept the newer versions as well? They should be compatible, shouldn't they?
Comment 1 Andrew Overholt 2009-02-20 09:30:02 EST
This looks more like an issue with tomcat itself.  Moving component to see if the maintainer has any idea.
Comment 2 Dirk Hoffmann 2009-02-21 15:57:34 EST
> --- Comment #1 from Andrew Overholt <overholt@redhat.com>  2009-02-20 09:30:0$
> This looks more like an issue with tomcat itself.  Moving component to see if
> the maintainer has any idea.

Yes, exactly. (I did not want to drop the principal consequence, why this is important for me. - I have no chance to use the official Fedora-Eclipse!)

The error is reproducible in short by     
 sudo yum install tomcat5-common-lib,
of course.
Comment 3 Dirk Hoffmann 2009-02-21 16:49:35 EST
In case anybody else runs into the same problem, here is a workaround:

1) Download tomcat5-jasper-5.5.26-1jpp.2.fc9.i386.rpm (from any Fedora RPM mirror)
2) yum localinstall tomcat5-jasper-5.5.26-1jpp.2.fc9.i386.rpm
2a) This should fail. Make sure it _only_ fails because of the missing 
 tomcat5-servlet-2.4-api = 5.5.26-1jpp.2.fc9, required by tomcat5-jasper.
2b) Eventually install other missing dependencies by hand, alike 
 yum install otherpkg1 otherpkg2 ...
3) rpm -i tomcat5-jasper-5.5.26-1jpp.2.fc9.i386.rpm --nodeps
3a) You may try without --nodeps, if you want to be 150% sure that only the tomcat5-servlet dependence will be ignored.
4) Download tomcat5-common-lib-5.5.26-1jpp.2.fc9.i386.rpm (see 1))
5) yum localinstall tomcat5-common-lib-5.5.26-1jpp.2.fc9.i386.rpm 
5a) See 2a/b), and accept _only_ missing 
 tomcat5-servlet-2.4-api = 5.5.26-1jpp.2.fc9 and
 tomcat5-jsp-2.0-api = 5.5.26-1jpp.2.fc9, required by tomcat5-common-lib
5b) You installed all other packages by hand (see 2b), right?
6) See 3a)
 rpm -i tomcat5-common-lib-5.5.26-1jpp.2.fc9.i386.rpm --nodeps
(without and) with --nodeps.
7) Make sure you have newer versions of tomcat5-servlet and tomcat5-jsp installed:
 yum list | grep tomcat5
The corresponding lines should list "installed" in the last column.
(NB: If you have 5.5.26 releases of these packages installed, you should not have come here in the first place.)

Now tomcat5-common-lib is installed. 

And I succeeded to install the eclipse-platform package from the Fedora repository. It works up to now without problems (besides a security issue, which I beleive is not related to tomcat5-common-libs).
Comment 4 Christopher Beland 2009-03-13 02:50:20 EDT
On my Fedora 9 installation today, both "yum install eclipse-platform" and "yum install tomcat5-common-lib" are succeeding in resolving dependencies and asking for confirmation to install.  So, I assume this has been fixed by subsequent updates.  If anyone is still experiencing this problem, feel free to re-open this bug.
Comment 5 Dirk Hoffmann 2009-03-25 18:44:41 EDT
I do not think the dependency problem is solved. I obtain the following outputs still:

$ yum list | grep '^tomcat5' | grep installed
tomcat5.i386                             5.5.26-1jpp.2.fc9      installed       
tomcat5-common-lib.i386                  5.5.26-1jpp.2.fc9      installed       
tomcat5-jasper.i386                      5.5.26-1jpp.2.fc9      installed       
tomcat5-jasper-eclipse.i386              5.5.26-1jpp.2.fc9      installed       
tomcat5-jsp-2.0-api.i386                 5.5.27-0jpp.2.fc9      installed       
tomcat5-server-lib.i386                  5.5.26-1jpp.2.fc9      installed       
tomcat5-servlet-2.4-api.i386             5.5.27-0jpp.2.fc9      installed       

$ yum deplist tomcat5-jasper | grep tomcat
paquetage : tomcat5-jasper.i386 5.5.26-1jpp.2.fc9
  dépendance : tomcat5-servlet-2.4-api = 5.5.26-1jpp.2.fc9
   provider: tomcat5-servlet-2.4-api.i386 5.5.26-1jpp.2.fc9

This means for me, "yum" will still require tomcat5-servlet (and tomcat5-jsp) in version 5.5.26, whereas they are installed as of 5.5.27 on my system, and I do not see a way to revert to 5.5.26. A quick "sudo yum reinstall tomcat5-jasper" confirms this assumption; it gives equivalent output as explained above for the original "yum install tomcat5-jasper" attempt.

Which versions of tomcat5 packages do you have installed on your system? Did you make a complete update recently?
Comment 6 Andrew Overholt 2009-03-30 09:36:12 EDT
David, can you please take a look?
Comment 7 Alexander Kurtakov 2009-06-04 07:00:18 EDT
Is this problem still present?
Comment 8 Dirk Hoffmann 2009-06-04 08:19:20 EDT
Yes, it is!

Can you help with it?

I even have another problem with wrongly declared dependencies in Fedora9: The latest vlc-core update requires /usr/lib/libass.so.3, which I had not installed before. However, the right _RPM_ to require would be libass, which contains this library.
Comment 9 Andrew Overholt 2009-06-04 09:52:56 EDT
David, can you please fix this problem?
Comment 10 Andrew Overholt 2009-06-04 09:53:29 EDT
(In reply to comment #8)
> I even have another problem with wrongly declared dependencies in Fedora9: The
> latest vlc-core update requires /usr/lib/libass.so.3, which I had not installed
> before. However, the right _RPM_ to require would be libass, which contains
> this library.  

Sorry, I don't know what is going on there.
Comment 11 Dirk Hoffmann 2009-06-05 04:27:25 EDT
>
> Sorry, I don't know what is going on there.
>

Then I am not sure my problems can be solved here (in this group, community, thread, whatever). I am sorry, but I have no insight how bugfixing for Fedora is organised, and I may knock at the wrong door.

What I know is that I observe two similar problems, both related to the question "Which RPM is declared to depend on which RPM." The declaration is obviously wrong for the two cases I mentioned. 

What I do not know, is if the developers or persons in charge for a given application are also 100% responsible for constructing its RPM and in particular for defining its dependencies on other packages (RPMs). If they are not, we need to find out who is responsible for the dependencies and forward this thread to the appropriate people.
Comment 12 Christopher Beland 2009-06-05 05:10:49 EDT
Dirk, from what I can tell, vlc-core is only distributed by third-party repositories, such as RPMFusion?  Most likely the problem is with the vlc-core RPM, and the thing to do would be to file a new bug with whatever vendor you are getting that from.  "rpm -qi vlc-core" should tell you that.

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 13 Bug Zapper 2009-06-09 23:34:35 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Andrew Overholt 2009-06-10 10:51:15 EDT
It's a shame that Eclipse wasn't installed in Fedora 9 for so long due to a tomcat packaging issue :(
Comment 15 Bug Zapper 2009-07-14 13:54:46 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.